aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-05-23 23:23:29 -0700
committerGitHub <noreply@github.com>2019-05-23 23:23:29 -0700
commit3713fa89c3ff5675c3652a9155be98df8b1b7959 (patch)
tree5a2033eb08c10e66cfc084220debc9318850ef86
parent3d62778f6e4aac138fe9e239882c043f451a7ba1 (diff)
parent61702f6b2f0ba6a7b78c49e66d98b00e7b0a4939 (diff)
Merge pull request #9041 from neheb/sla
slang2: Add support for full NLS compilation
-rw-r--r--libs/slang2/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/libs/slang2/Makefile b/libs/slang2/Makefile
index 568af53b9..0d33b08a0 100644
--- a/libs/slang2/Makefile
+++ b/libs/slang2/Makefile
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=slang
PKG_VERSION:=2.3.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://www.jedsoft.org/releases/slang \
@@ -22,12 +22,13 @@ PKG_LICENSE:=GPL-2.0+
PKG_LICENSE_FILES:=COPYING
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
-PKG_BUILD_PARALLEL:=1
+PKG_BUILD_PARALLEL:=0
SLANG_MODULES:= base64 chksum csv fcntl fork histogram iconv json pcre png \
rand select slsmg socket stats sysconf termios varray zlib
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
define Package/libslang2/Default
SECTION:=libs
@@ -63,6 +64,12 @@ $(call Package/libslang2/Default/description)
This installs all of S-Lang's bundled modules.
endef
+define Package/libslang2-mod-iconv
+$(call Package/libslang2/Default)
+ TITLE+= (iconv module)
+ DEPENDS:=$(ICONV_DEPENDS)
+endef
+
define Package/libslang2-mod-pcre
$(call Package/libslang2/Default)
TITLE+= (pcre module)
@@ -101,6 +108,7 @@ CONFIGURE_ARGS+= \
--enable-warnings \
--with-terminfo=default \
--with-readline=slang \
+ --with-iconv="$(ICONV_PREFIX)" \
--with-pcre="$(STAGING_DIR)/usr" \
--with-png="$(STAGING_DIR)/usr" \
--with-z="$(STAGING_DIR)/usr" \