aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-07 18:51:00 -0800
committerRosen Penev <rosenp@gmail.com>2020-12-07 20:11:08 -0800
commit3644cb7c14fadeb180f570102e94d6fee302589b (patch)
tree88b3e83c8adacdbd0dfe5683d4cb3b38badf5024
parentea80600e3c390025b617aa8b25382c228f4c5b01 (diff)
libgphoto2: install config files to host
Helps old packages that don't use pkgconfig. Remove old entries for previous versions of libgphoto2. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--libs/libgphoto2/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/libs/libgphoto2/Makefile b/libs/libgphoto2/Makefile
index 4181e7f73..8fcbd033d 100644
--- a/libs/libgphoto2/Makefile
+++ b/libs/libgphoto2/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libgphoto2
PKG_VERSION:=2.5.26
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PORT_VERSION:=0.12.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -473,16 +473,18 @@ TARGET_CFLAGS += $(FPIC)
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gphoto2{,-port}-config $(1)/usr/bin/
+ $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' $(1)/usr/bin/gphoto2{,-port}-config
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/gphoto2 $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgphoto2{,_port}.{a,so*} $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libgphoto2{,_port}.pc $(1)/usr/lib/pkgconfig/
- $(SED) 's,-I$$$${prefix}/include/gphoto2,,g' $(1)/usr/bin/gphoto2{,-port}-config
- $(SED) 's,-I$$$${prefix}/include,,g' $(1)/usr/bin/gphoto2{,-port}-config
# remove annoying recursive symlink
rm -f $(1)/usr/include/gphoto2/gphoto2
+ $(INSTALL_DIR) $(2)/bin
+ $(LN) ../../usr/bin/gphoto2-config $(2)/bin/gphoto2-config
+ $(LN) ../../usr/bin/gphoto2-port-config $(2)/bin/gphoto2-port-config
endef
define Package/libgphoto2/install