aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCezary Jackiewicz <cezary.jackiewicz@gmail.com>2014-07-22 22:38:10 +0200
committerCezary Jackiewicz <cezary.jackiewicz@gmail.com>2014-07-22 22:38:10 +0200
commit35e235ab07d7a4e116bd0905be2ba3c9ed4e72f6 (patch)
tree4fa095e39b20edf7f3470fe296412ae692041aa9
parent7884c022acdce8c13eaeea8108822122b2131027 (diff)
Import aria2 from oldpackages, update to 1.18.7
-rw-r--r--net/aria2/Config.in28
-rw-r--r--net/aria2/Makefile70
2 files changed, 98 insertions, 0 deletions
diff --git a/net/aria2/Config.in b/net/aria2/Config.in
new file mode 100644
index 000000000..ec21fafe7
--- /dev/null
+++ b/net/aria2/Config.in
@@ -0,0 +1,28 @@
+menu "Aria2 configuration"
+ depends on PACKAGE_aria2
+
+choice
+ prompt "SSL library"
+ default ARIA2_OPENSSL
+
+config ARIA2_OPENSSL
+ bool "OpenSSL"
+
+config ARIA2_GNUTLS
+ bool "GNUTLS"
+
+config ARIA2_NOSSL
+ bool "No SSL support"
+
+endchoice
+
+config ARIA2_BITTORRENT
+ bool "Enable bittorrent support"
+ depends on ARIA2_OPENSSL
+ default n
+
+config ARIA2_METALINK
+ bool "Enable metalink support"
+ default N
+
+endmenu
diff --git a/net/aria2/Makefile b/net/aria2/Makefile
new file mode 100644
index 000000000..cac017a6c
--- /dev/null
+++ b/net/aria2/Makefile
@@ -0,0 +1,70 @@
+#
+# Copyright (C) 2012-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=aria2
+PKG_VERSION:=1.18.7
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/aria2
+PKG_MD5SUM:=36e92af92b4370817c577ed802546842
+PKG_INSTALL:=1
+
+PKG_MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+PKG_LICENSE:=GPLv2
+PKG_LICENSE_FILES:=COPYING
+
+PKG_CONFIG_DEPENDS := \
+ ARIA2_NOSSL \
+ ARIA2_OPENSSL \
+ ARIA2_GNUTLS \
+ ARIA2_BITTORRENT \
+ ARIA2_METALINK
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/aria2/config
+ source "$(SOURCE)/Config.in"
+endef
+
+define Package/aria2
+ SECTION:=net
+ CATEGORY:=Network
+ SUBMENU:=File Transfer
+ TITLE:=lightweight download utility
+ URL:=http://aria2.sourceforge.net/
+ DEPENDS:=+zlib +ARIA2_METALINK:libxml2 +libstdcpp +ARIA2_OPENSSL:libopenssl +ARIA2_GNUTLS:libgnutls
+endef
+
+define Package/aria2/description
+ aria2 is a lightweight multi-protocol & multi-source command-line download
+ utility
+endef
+
+CONFIGURE_ARGS += \
+ --disable-nls \
+ $(if $(CONFIG_ARIA2_NOSSL),--disable,--enable)-ssl \
+ $(if $(CONFIG_ARIA2_OPENSSL),--with,--without)-openssl \
+ $(if $(CONFIG_ARIA2_GNUTLS),--with,--without)-gnutls \
+ $(if $(CONFIG_ARIA2_BITTORRENT),--enable,--disable)-bittorrent \
+ $(if $(CONFIG_ARIA2_METALINK),--enable,--disable)-metalink \
+ $(if $(CONFIG_ARIA2_METALINK),--with,--without)-libxml2 \
+ --without-libnettle \
+ --without-libgmp \
+ --without-libgcrypt \
+ --without-libexpat \
+ --without-libcares \
+ --without-sqlite3 \
+ --with-libz
+
+define Package/aria2/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aria2c $(1)/usr/bin
+endef
+
+$(eval $(call BuildPackage,aria2))