aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOthmar Truniger <github@truniger.ch>2016-02-11 19:00:37 +0100
committerOthmar Truniger <github@truniger.ch>2016-02-11 19:00:37 +0100
commit3448cd93855b0f4869ca470a3bde4a7d5f1ca041 (patch)
tree1d2a4d42699bcdda6c239f4c12940f444e8652eb
parentac633e9f3fd11a01fbdc86a001770fd749f48385 (diff)
linknx: bump to new version on new repo
Signed-off-by: Othmar Truniger <github@truniger.ch>
-rw-r--r--net/linknx/Makefile18
-rw-r--r--net/linknx/patches/010-musl-compat10
-rw-r--r--net/linknx/patches/012-fix-linknx.cpp11
3 files changed, 12 insertions, 27 deletions
diff --git a/net/linknx/Makefile b/net/linknx/Makefile
index 3af3842be..fd3032d9b 100644
--- a/net/linknx/Makefile
+++ b/net/linknx/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2015 OpenWrt.org
+# Copyright (C) 2008-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,18 +8,24 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=linknx
-PKG_VERSION:=0.0.1.32
-PKG_RELEASE:=7
-PKG_MD5SUM:=7ecc1208f59bceb05068c752b2250b63
+PKG_VERSION:=0.0.1.33
+PKG_RELEASE:=1
PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
PKG_LICENSE:=GPL-2.0+
-PKG_SOURCE_URL:=@SF/linknx
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/linknx/linknx.git
+PKG_SOURCE_VERSION:=f627ed44feaea5a1f67c53f2810c44a14c059cef
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)
+PKG_SOURCE:=$(PKG_NAME)-${PKG_VERSION}.tar.gz
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
PKG_BUILD_DEPENDS:=argp-standalone
PKG_FORTIFY_SOURCE:=1
+PKG_FIXUP:=autoreconf
+
include $(INCLUDE_DIR)/package.mk
define Package/linknx
diff --git a/net/linknx/patches/010-musl-compat b/net/linknx/patches/010-musl-compat
deleted file mode 100644
index 15c757ee0..000000000
--- a/net/linknx/patches/010-musl-compat
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/eibclient.c 2007-10-11 01:55:31.000000000 +0200
-+++ b/src/eibclient.c 2015-06-27 22:18:01.433296921 +0200
-@@ -32,6 +32,7 @@
- #include <netinet/in.h>
- #include <netdb.h>
- #include <errno.h>
-+#include <string.h>
-
- #include "config.h"
-
diff --git a/net/linknx/patches/012-fix-linknx.cpp b/net/linknx/patches/012-fix-linknx.cpp
deleted file mode 100644
index 8394cf12e..000000000
--- a/net/linknx/patches/012-fix-linknx.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/linknx.cpp 2012-06-04 22:12:13.000000000 +0200
-+++ b/src/linknx.cpp 2015-06-27 22:35:23.705721355 +0200
-@@ -136,7 +136,7 @@
- if (errno)
- printf (": %s\n", strerror (errno));
- else
-- printf ("\n", strerror (errno));
-+ printf ("\n");
- exit (1);
- }
-