aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-02-27 10:15:07 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2024-02-27 23:45:41 +0200
commit3444a614ed6e6b0645bfe1fdb748c83700d1605e (patch)
treef4aa92a61d1cf182aa3ab3f40fc895746488b5dc
parentfc4596ddc4395263bcd237481229f72efa257bfd (diff)
openthread-br: modernize CMake options
- ':BOOL' suffix is not needed - Don't set options which are matching the defaults - Rename non-existing OT_BORDER_ROUTING_NAT64 to OTBR_NAT64 Signed-off-by: krant <aleksey.vasilenko@gmail.com>
-rw-r--r--net/openthread-br/Makefile33
1 files changed, 14 insertions, 19 deletions
diff --git a/net/openthread-br/Makefile b/net/openthread-br/Makefile
index 35c3b969d..9ce8803cc 100644
--- a/net/openthread-br/Makefile
+++ b/net/openthread-br/Makefile
@@ -53,26 +53,21 @@ define Package/openthread-br/conffiles
endef
CMAKE_OPTIONS += \
- -DOT_BORDER_ROUTER:BOOL=ON \
- -DOT_BORDER_ROUTING_NAT64:BOOL=ON \
- -DOT_CHANNEL_MANAGER:BOOL=ON \
- -DOT_CHANNEL_MONITOR:BOOL=ON \
- -DOT_COMMISSIONER:BOOL=ON \
- -DOT_ECDSA:BOOL=ON \
- -DOT_FIREWALL:BOOL=OFF \
- -DOT_SERVICE:BOOL=ON \
- -DOT_SRP_CLIENT:BOOL=ON \
- -DOT_SRP_SERVER:BOOL=ON \
- -DOTBR_BACKBONE_ROUTER:BOOL=ON \
- -DOTBR_BORDER_ROUTING:BOOL=ON \
- -DOTBR_DNSSD_DISCOVERY_PROXY:BOOL=ON \
- -DOTBR_DUA_ROUTING:BOOL=ON \
+ -DOT_BORDER_ROUTER=ON \
+ -DOT_CHANNEL_MANAGER=ON \
+ -DOT_CHANNEL_MONITOR=ON \
+ -DOT_FIREWALL=OFF \
+ -DOTBR_BACKBONE_ROUTER=ON \
+ -DOTBR_BORDER_ROUTING=ON \
+ -DOTBR_DNSSD_DISCOVERY_PROXY=ON \
+ -DOTBR_DUA_ROUTING=ON \
-DOTBR_MDNS=mDNSResponder \
- -DOTBR_OPENWRT:BOOL=ON \
- -DOTBR_REST:BOOL=ON \
- -DOTBR_SRP_ADVERTISING_PROXY:BOOL=ON \
- -DOTBR_SRP_SERVER_AUTO_ENABLE:BOOL=ON \
- -DOTBR_TREL:BOOL=ON
+ -DOTBR_NAT64=ON \
+ -DOTBR_OPENWRT=ON \
+ -DOTBR_REST=ON \
+ -DOTBR_SRP_ADVERTISING_PROXY=ON \
+ -DOTBR_SRP_SERVER_AUTO_ENABLE=ON \
+ -DOTBR_TREL=ON
TARGET_CFLAGS += -DOPENTHREAD_POSIX_CONFIG_DAEMON_SOCKET_BASENAME=\\\"/var/run/openthread-%s\\\"