aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-11-12 19:08:30 -0800
committerGitHub <noreply@github.com>2019-11-12 19:08:30 -0800
commit323dbc4fbf2ca9dff7f883134c04ed2d028a2cb0 (patch)
tree9b48fa7c69796aea9910e188443e095ef6e12a0f
parentef97cde4819beebb871e4cefe2a7ece50c5078d3 (diff)
parentefe695f93d6bc753d00d39efcb1671ab1ecb1e30 (diff)
Merge pull request #10469 from peter-stadler/django-etesync-journal
django-etesync-journal: add python3 package
-rw-r--r--lang/python/python3-django-etesync-journal/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/lang/python/python3-django-etesync-journal/Makefile b/lang/python/python3-django-etesync-journal/Makefile
new file mode 100644
index 000000000..f331eca50
--- /dev/null
+++ b/lang/python/python3-django-etesync-journal/Makefile
@@ -0,0 +1,35 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=django-etesync-journal
+PKG_VERSION:=1.0.3
+PKG_RELEASE:=1
+
+PYPI_NAME:=django-etesync-journal
+PKG_HASH:=a81674fab37913831c93107e3335030b0f8eeef074c0abb202aedc9b61a61bac
+
+PKG_LICENSE:=AGPL-3.0-only
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Peter Stadler <peter.stadler@student.uibk.ac.at>
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-django-etesync-journal
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=The server side implementation of the EteSync protocol.
+ URL:=https://www.etesync.com/
+ DEPENDS:=python3-django +python3-django-restframework +python3-light
+ VARIANT:=python3
+ MDEPENDS:=python3-django
+endef
+
+define Package/python3-django-etesync-journal/description
+ The reusable django app that implements the server side of the EteSync protocol.
+endef
+
+$(eval $(call Py3Package,python3-django-etesync-journal))
+$(eval $(call BuildPackage,python3-django-etesync-journal))
+$(eval $(call BuildPackage,python3-django-etesync-journal-src))