aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-11-25 14:23:25 -0800
committerGitHub <noreply@github.com>2020-11-25 14:23:25 -0800
commit3116b22dd37ab36de3fa811cea2c7a7cff2a675a (patch)
tree980477114241b2d4bb18e9fcb6af2e703bb233bb
parent3cce7bdd724c46a206ed15ecc54dda698dd19034 (diff)
parentd97056efe5d98ab703370da315674ba9552eed79 (diff)
Merge pull request #14012 from neheb/dmx
dmx_usb_module: update to 19.12.1
-rw-r--r--libs/dmx_usb_module/Makefile17
-rw-r--r--libs/dmx_usb_module/patches/001-dmx_usb_Makefile.patch7
-rw-r--r--libs/dmx_usb_module/patches/002-fix-build-4.14.patch11
3 files changed, 11 insertions, 24 deletions
diff --git a/libs/dmx_usb_module/Makefile b/libs/dmx_usb_module/Makefile
index 8f7184067..971648cfa 100644
--- a/libs/dmx_usb_module/Makefile
+++ b/libs/dmx_usb_module/Makefile
@@ -9,16 +9,15 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=dmx_usb_module
-PKG_VERSION:=0.1.20130818
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_URL:=https://github.com/lowlander/dmx_usb_module.git
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=ee99ca7edbd9e093480ad63341ac007394047bde
+PKG_VERSION:=19.12.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/lowlander/dmx_usb_module/tar.gz/V$(PKG_VERSION)?
+PKG_HASH:=fabeb5500b55197338dda45d07374e5edc837bc18df3ac3114b442fe47cf1b68
+
PKG_MAINTAINER:=Martijn Zilverschoon <martijn@friedzombie.com>
-PKG_LICENSE:=GPL-2.0
+PKG_LICENSE:=GPL-2.0-only
include $(INCLUDE_DIR)/package.mk
diff --git a/libs/dmx_usb_module/patches/001-dmx_usb_Makefile.patch b/libs/dmx_usb_module/patches/001-dmx_usb_Makefile.patch
index 2a03d9484..473e961be 100644
--- a/libs/dmx_usb_module/patches/001-dmx_usb_Makefile.patch
+++ b/libs/dmx_usb_module/patches/001-dmx_usb_Makefile.patch
@@ -1,13 +1,12 @@
--- a/Makefile
+++ b/Makefile
-@@ -12,8 +12,7 @@ KDIR := /lib/modules/$(shell uname -r)/build
+@@ -12,8 +12,7 @@ KDIR := /lib/modules/$(shell uname -r)/b
PWD := $(shell pwd)
default:
-- $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
+- $(MAKE) -C $(KDIR) M=$(PWD)
- gcc -O2 -pipe -Wall dmx_usb_test.c -o dmx_usb_test
-+ $(MAKE) -C $(KERNELPATH) SUBDIRS=$(PWD) modules
++ $(MAKE) -C $(KERNELPATH) M=$(PWD)
endif
-
diff --git a/libs/dmx_usb_module/patches/002-fix-build-4.14.patch b/libs/dmx_usb_module/patches/002-fix-build-4.14.patch
deleted file mode 100644
index e3ae11e82..000000000
--- a/libs/dmx_usb_module/patches/002-fix-build-4.14.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/dmx_usb.c
-+++ b/dmx_usb.c
-@@ -20,7 +20,7 @@
- #include <linux/module.h>
- #include <linux/spinlock.h>
- #include <linux/completion.h>
--#include <asm/uaccess.h>
-+#include <linux/uaccess.h>
- #include <linux/usb.h>
- #include <linux/version.h>
-