aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHirokazu MORIKAWA <morikw2@gmail.com>2020-12-28 13:32:09 +0900
committerHirokazu MORIKAWA <morikw2@gmail.com>2020-12-28 13:32:09 +0900
commit31123a08f906893b561c699d114d6b8bf01a3830 (patch)
treef73d40812153d776801da89d8df6859044043ab6
parent4b96bbfaccce1dc8a1229ac2d5679d9bf2cb2944 (diff)
node-homebridge: update to 1.2.4
Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
-rw-r--r--lang/node-homebridge/Makefile6
-rw-r--r--lang/node-homebridge/patches/000-add_module_search_path.patch2
2 files changed, 4 insertions, 4 deletions
diff --git a/lang/node-homebridge/Makefile b/lang/node-homebridge/Makefile
index 080c2d2d2..209e1a0bf 100644
--- a/lang/node-homebridge/Makefile
+++ b/lang/node-homebridge/Makefile
@@ -6,12 +6,12 @@ include $(TOPDIR)/rules.mk
PKG_NPM_NAME:=homebridge
PKG_NAME:=node-$(PKG_NPM_NAME)
-PKG_VERSION:=1.2.3
+PKG_VERSION:=1.2.4
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NPM_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=https://registry.npmjs.org/$(PKG_NPM_NAME)/-/
-PKG_HASH:=80f1bbd2021942f4ec47d662f9ec208ca7fb7490d981cdc409f19809604cb592
+PKG_HASH:=f91ab0058707a0498d97d87f45f19682065f80660fac942e0985caf9bb205f2a
PKG_BUILD_DEPENDS:=node/host
PKG_USE_MIPS16:=0
@@ -70,7 +70,7 @@ define Package/node-homebridge/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/node_modules/$(PKG_NPM_NAME)/{LICENSE,bin} \
$(1)/usr/lib/node/$(PKG_NPM_NAME)/
$(INSTALL_DIR) $(1)/usr/bin
- $(LN) ../lib/node/homebridge/bin/homebridge $(1)/usr/bin/homebridge
+ $(LN) ../lib/node/$(PKG_NPM_NAME)/bin/homebridge $(1)/usr/bin/homebridge
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/homebridge.init $(1)/etc/init.d/homebridge
endef
diff --git a/lang/node-homebridge/patches/000-add_module_search_path.patch b/lang/node-homebridge/patches/000-add_module_search_path.patch
index 911182c18..cd9b40dac 100644
--- a/lang/node-homebridge/patches/000-add_module_search_path.patch
+++ b/lang/node-homebridge/patches/000-add_module_search_path.patch
@@ -1,6 +1,6 @@
--- a/lib/pluginManager.js
+++ b/lib/pluginManager.js
-@@ -324,6 +324,7 @@
+@@ -324,6 +324,7 @@ class PluginManager {
else {
this.searchPaths.add("/usr/local/lib/node_modules");
this.searchPaths.add("/usr/lib/node_modules");