aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2021-01-19 22:03:45 -0300
committerEneas U de Queiroz <cotequeiroz@gmail.com>2021-02-24 21:00:13 -0300
commit30a8d8db6aa5c96799b9d869be62cda5fb14fd88 (patch)
tree5cfbb72bed3d0d07de04fea98efb8022b0bb027e
parentd8203191cc9ee7d74d8304eb8c6d1954789a0c12 (diff)
libupm: enforce disabling python2
If there are more than two python3 interpreters, and no python2, libupm thinks one of them is python2 and fails. Avoid that by telling it that python2 was not found. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
-rw-r--r--libs/libupm/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/libs/libupm/Makefile b/libs/libupm/Makefile
index 7f0b14de7..303b26ba2 100644
--- a/libs/libupm/Makefile
+++ b/libs/libupm/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libupm
PKG_VERSION:=2.0.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/intel-iot-devkit/upm/tar.gz/v$(PKG_VERSION)?
@@ -53,7 +53,9 @@ UPM_MODULES:= \
# (require libbacnet) tb7300 t8100 e50hx bacnetmstp
# (require libtinyb) 2jciebu01_ble 2jciebu01_usb
-CMAKE_OPTIONS=-DBUILDSWIGNODE=$(if $(CONFIG_PACKAGE_libmraa-node),ON,OFF)
+CMAKE_OPTIONS=-DBUILDSWIGNODE=$(if $(CONFIG_PACKAGE_libmraa-node),ON,OFF) \
+ -DPYTHON2LIBS_FOUND=FALSE \
+ -DPYTHON2INTERP_FOUND=FALSE \
define Package/libupm/Default
SECTION:=libs