aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-07 20:58:52 -0800
committerGitHub <noreply@github.com>2020-12-07 20:58:52 -0800
commit307073d4b05f174e38bad3833a5bc80f1ab09626 (patch)
treeef120079c92af783fdc2c498385f87af416e5143
parent8ebe927a848a62b6b26cc511fae07e2e161e9f76 (diff)
parentf995f4485a62a5fb72fe66d9faeaa9ca0c0c0b19 (diff)
Merge pull request #14163 from neheb/krb
krb5: install krb5-config to host
-rw-r--r--net/krb5/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/krb5/Makefile b/net/krb5/Makefile
index 54bf36c59..6ea88b0dd 100644
--- a/net/krb5/Makefile
+++ b/net/krb5/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=krb5
PKG_VERSION:=1.18.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
@@ -102,6 +102,9 @@ define Build/InstallDev
# needed for samba4, to detect system-krb5
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/krb5-config $(1)/usr/bin
+ $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' $(1)/usr/bin/krb5-config
+ $(INSTALL_DIR) $(2)/bin
+ $(LN) ../../usr/bin/krb5-config $(2)/bin/krb5-config
endef
define Package/krb5-libs/install