aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2023-11-16 13:00:19 -0800
committerRosen Penev <rosenp@gmail.com>2023-11-16 18:06:06 -0800
commit303b7b665c5f2aa177d1c4ebbc4346eafd51809b (patch)
treeba46e9de3fc7564409d8271aba8ad4d1fa6b2681
parentf53100b69e775caa01a53e48308e95b823fabfdc (diff)
upmpdcli: update to 1.8.4
Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--sound/upmpdcli/Makefile4
-rw-r--r--sound/upmpdcli/patches/010-gcc13.patch10
2 files changed, 12 insertions, 2 deletions
diff --git a/sound/upmpdcli/Makefile b/sound/upmpdcli/Makefile
index 6d7a0626c..e45dcb049 100644
--- a/sound/upmpdcli/Makefile
+++ b/sound/upmpdcli/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=upmpdcli
-PKG_VERSION:=1.5.19
+PKG_VERSION:=1.8.4
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.lesbonscomptes.com/upmpdcli/downloads
-PKG_HASH:=67fa1f5c06fecd404f3414b25a070c9deabe917241ed6881b7a8e41e8379ed09
+PKG_HASH:=91f40093d7465eb26edbc08cb93fbdd277ea83b8dbb753491c53497a4644ee87
PKG_MAINTAINER:=
PKG_LICENSE:=LGPL-2.1-or-later
diff --git a/sound/upmpdcli/patches/010-gcc13.patch b/sound/upmpdcli/patches/010-gcc13.patch
new file mode 100644
index 000000000..63e397982
--- /dev/null
+++ b/sound/upmpdcli/patches/010-gcc13.patch
@@ -0,0 +1,10 @@
+--- a/src/upmpdutils.hxx
++++ b/src/upmpdutils.hxx
+@@ -17,6 +17,7 @@
+ #ifndef _UPMPDUTILS_H_X_INCLUDED_
+ #define _UPMPDUTILS_H_X_INCLUDED_
+
++#include <cstdint>
+ #include <string>
+ #include <unordered_map>
+ #include <vector>