aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel F. Dickinson <cshored@thecshore.com>2018-08-16 18:11:42 -0400
committerDaniel F. Dickinson <cshored@thecshore.com>2018-08-19 14:35:38 -0400
commit2b7531ad9fa767fdcbf1b7d1e9a02a56678bdbea (patch)
tree48967462cc6eb65d4a1b3303850119bb31f9b527
parentf0fb968346dea9bbe8ff3872b9ade5e3a88f4e18 (diff)
doveco: pigeonhole: Use stock dovecot dir locations
We move dovecot libexec binaries and modules (including the package pigeonhole) to their standard locations. This is okay for libexec because it was added to core prior to 17.04 release. Moving the binaries normally in libexec eliminates the reason the modules were in an unusual directory, which is that there were conflicts with libexec binaries that were in lib, which the modules normally use. Signed-off-by: Daniel F. Dickinson <cshored@thecshore.com>
2 files changed, 5 insertions, 2 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index 3b06d98c7..17bccd1b2 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -98,8 +98,8 @@ define Package/dovecot-utils
endef
CONFIGURE_ARGS += \
+ --libexecdir=/usr/libexec \
--without-pam \
- --with-moduledir=/usr/lib/dovecot/modules \
--with-notify=dnotify \
--without-lzma \
--without-lz4 \
@@ -137,10 +137,12 @@ define Package/dovecot/install
$(1)/etc/dovecot \
$(1)/usr/share/doc/dovecot \
$(1)/usr/lib/dovecot \
+ $(1)/usr/libexec/dovecot \
$(1)/usr/bin \
$(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/etc/dovecot/* $(1)/etc/dovecot/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/dovecot/* $(1)/usr/lib/dovecot/
+ $(CP) $(PKG_INSTALL_DIR)/usr/libexec/dovecot/* $(1)/usr/libexec/dovecot/
$(CP) $(PKG_INSTALL_DIR)/usr/share/doc/dovecot/example-config $(1)/usr/share/doc/dovecot/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/doveconf $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
diff --git a/mail/pigeonhole/Makefile b/mail/pigeonhole/Makefile
index 6772b9a67..9956483e3 100644
--- a/mail/pigeonhole/Makefile
+++ b/mail/pigeonhole/Makefile
@@ -50,9 +50,10 @@ CONFIGURE_VARS += \
CPPFLAGS="$(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/dovecot/"
define Package/dovecot-pigeonhole/install
- $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib/dovecot/
+ $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib/dovecot/ $(1)/usr/libexec/dovecot/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/dovecot/* $(1)/usr/lib/dovecot/
+ $(CP) $(PKG_INSTALL_DIR)/usr/libexec/dovecot/* $(1)/usr/libexec/dovecot/
find $(1)/usr/lib/dovecot/ -name "*.a" -o -name "*.la" | xargs rm
endef