aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-10-09 09:18:40 +0800
committerJeffery To <jeffery.to@gmail.com>2023-10-09 09:20:50 +0800
commit2aba43afe9e1bf5d9dc5e3578af7f82f6da51b2b (patch)
tree5bf90fb27dd4f7daeb545c6fb4579f968d1783e3
parentaf48372e3740713595a07330316276259162edf6 (diff)
python3: Update to 3.11.6, refresh patches
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
-rw-r--r--lang/python/python3-version.mk2
-rw-r--r--lang/python/python3/Makefile2
-rw-r--r--lang/python/python3/patches/003-do-not-run-compileall.patch4
-rw-r--r--lang/python/python3/patches/025-choose-python-config-version.patch2
4 files changed, 5 insertions, 5 deletions
diff --git a/lang/python/python3-version.mk b/lang/python/python3-version.mk
index 4e503fb6e..5712e0f1d 100644
--- a/lang/python/python3-version.mk
+++ b/lang/python/python3-version.mk
@@ -8,7 +8,7 @@
# Note: keep in sync with setuptools & pip
PYTHON3_VERSION_MAJOR:=3
PYTHON3_VERSION_MINOR:=11
-PYTHON3_VERSION_MICRO:=5
+PYTHON3_VERSION_MICRO:=6
PYTHON3_VERSION:=$(PYTHON3_VERSION_MAJOR).$(PYTHON3_VERSION_MINOR)
diff --git a/lang/python/python3/Makefile b/lang/python/python3/Makefile
index 14915715b..c55570576 100644
--- a/lang/python/python3/Makefile
+++ b/lang/python/python3/Makefile
@@ -16,7 +16,7 @@ PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
-PKG_HASH:=85cd12e9cf1d6d5a45f17f7afe1cebe7ee628d3282281c492e86adf636defa3f
+PKG_HASH:=0fab78fa7f133f4f38210c6260d90d7c0d5c7198446419ce057ec7ac2e6f5f38
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
PKG_LICENSE:=Python-2.0.1 0BSD
diff --git a/lang/python/python3/patches/003-do-not-run-compileall.patch b/lang/python/python3/patches/003-do-not-run-compileall.patch
index 9bb10fac7..ed79314f0 100644
--- a/lang/python/python3/patches/003-do-not-run-compileall.patch
+++ b/lang/python/python3/patches/003-do-not-run-compileall.patch
@@ -1,6 +1,6 @@
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
-@@ -2123,6 +2123,7 @@ libinstall: all $(srcdir)/Modules/xxmodu
+@@ -2128,6 +2128,7 @@ libinstall: all $(srcdir)/Modules/xxmodu
$(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
$(DESTDIR)$(LIBDEST)/distutils/tests ; \
fi
@@ -8,7 +8,7 @@
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi $(DESTDIR)$(LIBDEST)/compileall.py \
-j0 -d $(LIBDEST) -f \
-@@ -2150,6 +2151,7 @@ libinstall: all $(srcdir)/Modules/xxmodu
+@@ -2155,6 +2156,7 @@ libinstall: all $(srcdir)/Modules/xxmodu
$(PYTHON_FOR_BUILD) -Wi -OO $(DESTDIR)$(LIBDEST)/compileall.py \
-j0 -d $(LIBDEST)/site-packages -f \
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
diff --git a/lang/python/python3/patches/025-choose-python-config-version.patch b/lang/python/python3/patches/025-choose-python-config-version.patch
index aa56d8942..ca484f97b 100644
--- a/lang/python/python3/patches/025-choose-python-config-version.patch
+++ b/lang/python/python3/patches/025-choose-python-config-version.patch
@@ -1,6 +1,6 @@
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
-@@ -2168,7 +2168,7 @@ python-config: $(srcdir)/Misc/python-con
+@@ -2173,7 +2173,7 @@ python-config: $(srcdir)/Misc/python-con
@ # On Darwin, always use the python version of the script, the shell
@ # version doesn't use the compiler customizations that are provided
@ # in python (_osx_support.py).