aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2019-04-14 15:06:55 +0300
committerLucian Cristian <lucian.cristian@gmail.com>2019-04-14 22:28:01 +0300
commit291dfc8f168587b81ab5029e1f794d1f76fe5b34 (patch)
treee75e6c6a7e2b789687e686899582084e0f8b29de
parent3be5d4d840edc2dafb532304e2bb3b0671892b92 (diff)
libdrm: update and put me as a maintainer
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
-rw-r--r--libs/libdrm/Makefile27
-rw-r--r--libs/libdrm/patches/000-remove-dep-on-pthread-stubs.patch101
2 files changed, 14 insertions, 114 deletions
diff --git a/libs/libdrm/Makefile b/libs/libdrm/Makefile
index e0da214fc..93a28eedd 100644
--- a/libs/libdrm/Makefile
+++ b/libs/libdrm/Makefile
@@ -6,39 +6,40 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libdrm
-PKG_VERSION:=2.4.70
+PKG_VERSION:=2.4.97
PKG_RELEASE:=1
-PKG_SOURCE_URL:=http://dri.freedesktop.org/libdrm
+PKG_SOURCE_URL:=https://dri.freedesktop.org/libdrm
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_HASH:=b17d4b39ed97ca0e4cffa0db06ff609e617bac94646ec38e8e0579d530540e7b
+PKG_HASH:=77d0ccda3e10d6593398edb70b1566bfe1a23a39bd3da98ace2147692eadd123
PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
include $(INCLUDE_DIR)/package.mk
define Package/libdrm
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=
+ DEPENDS:=+libpciaccess
TITLE:=libdrm
- URL:=http://dri.freedesktop.org/
+ URL:=https://dri.freedesktop.org/
+endef
+
+define Package/libdrm/description
+ LIBDRM is the cross-driver middleware which allows user-space applications
+ (such as Mesa and 2D drivers) to communicate with the Kernel by the means
+ of the DRI protocol.
endef
CONFIGURE_ARGS += \
--disable-udev \
--enable-kms \
- --disable-intel \
- --disable-radeon \
- --disable-amdgpu \
- --disable-nouveau \
- --disable-vmwgfx \
--disable-omap-experimental-api \
--disable-exynos-experimental-api \
- --disable-freedreno \
- --disable-freedreno-kgsl \
--disable-tegra-experimental-api \
- --disable-vc4 \
--disable-cairo-tests \
--disable-manpages \
--disable-valgrind
diff --git a/libs/libdrm/patches/000-remove-dep-on-pthread-stubs.patch b/libs/libdrm/patches/000-remove-dep-on-pthread-stubs.patch
deleted file mode 100644
index 5da56a2ff..000000000
--- a/libs/libdrm/patches/000-remove-dep-on-pthread-stubs.patch
+++ /dev/null
@@ -1,101 +0,0 @@
---- a/configure 2016-07-23 15:19:06.000000000 +0200
-+++ b/configure 2016-08-27 01:11:02.440530337 +0200
-@@ -13334,98 +13334,6 @@
- fi
- fi
-
--pkg_failed=no
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for PTHREADSTUBS" >&5
--$as_echo_n "checking for PTHREADSTUBS... " >&6; }
--
--if test -n "$PTHREADSTUBS_CFLAGS"; then
-- pkg_cv_PTHREADSTUBS_CFLAGS="$PTHREADSTUBS_CFLAGS"
-- elif test -n "$PKG_CONFIG"; then
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"pthread-stubs\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "pthread-stubs") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_PTHREADSTUBS_CFLAGS=`$PKG_CONFIG --cflags "pthread-stubs" 2>/dev/null`
-- test "x$?" != "x0" && pkg_failed=yes
--else
-- pkg_failed=yes
--fi
-- else
-- pkg_failed=untried
--fi
--if test -n "$PTHREADSTUBS_LIBS"; then
-- pkg_cv_PTHREADSTUBS_LIBS="$PTHREADSTUBS_LIBS"
-- elif test -n "$PKG_CONFIG"; then
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"pthread-stubs\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "pthread-stubs") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_PTHREADSTUBS_LIBS=`$PKG_CONFIG --libs "pthread-stubs" 2>/dev/null`
-- test "x$?" != "x0" && pkg_failed=yes
--else
-- pkg_failed=yes
--fi
-- else
-- pkg_failed=untried
--fi
--
--
--
--if test $pkg_failed = yes; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
--
--if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
-- _pkg_short_errors_supported=yes
--else
-- _pkg_short_errors_supported=no
--fi
-- if test $_pkg_short_errors_supported = yes; then
-- PTHREADSTUBS_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "pthread-stubs" 2>&1`
-- else
-- PTHREADSTUBS_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "pthread-stubs" 2>&1`
-- fi
-- # Put the nasty error message in config.log where it belongs
-- echo "$PTHREADSTUBS_PKG_ERRORS" >&5
--
-- as_fn_error $? "Package requirements (pthread-stubs) were not met:
--
--$PTHREADSTUBS_PKG_ERRORS
--
--Consider adjusting the PKG_CONFIG_PATH environment variable if you
--installed software in a non-standard prefix.
--
--Alternatively, you may set the environment variables PTHREADSTUBS_CFLAGS
--and PTHREADSTUBS_LIBS to avoid the need to call pkg-config.
--See the pkg-config man page for more details." "$LINENO" 5
--elif test $pkg_failed = untried; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
--$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
--as_fn_error $? "The pkg-config script could not be found or is too old. Make sure it
--is in your PATH or set the PKG_CONFIG environment variable to the full
--path to pkg-config.
--
--Alternatively, you may set the environment variables PTHREADSTUBS_CFLAGS
--and PTHREADSTUBS_LIBS to avoid the need to call pkg-config.
--See the pkg-config man page for more details.
--
--To get pkg-config, see <http://pkg-config.freedesktop.org/>.
--See \`config.log' for more details" "$LINENO" 5; }
--else
-- PTHREADSTUBS_CFLAGS=$pkg_cv_PTHREADSTUBS_CFLAGS
-- PTHREADSTUBS_LIBS=$pkg_cv_PTHREADSTUBS_LIBS
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; }
--
--fi
--
--
-
- pkgconfigdir=${libdir}/pkgconfig
-