aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-06-13 03:36:41 +0800
committerTianling Shen <cnsztl@gmail.com>2023-06-14 13:46:44 +0800
commit27e6796a832e76ac4eee30de2347ad47c085c7ed (patch)
treef3b5858665f59950d953cc3e518d2f039cdb05df
parente7181b3452b6a32d5d7a567e8465ce3489126644 (diff)
cloudreve: Update to 3.8.0
- Fixed packing web frontend assets - Enabled build for riscv64 Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
1 files changed, 5 insertions, 3 deletions
diff --git a/net/cloudreve/Makefile b/net/cloudreve/Makefile
index 1d6a65e9a..b919f5b85 100644
--- a/net/cloudreve/Makefile
+++ b/net/cloudreve/Makefile
@@ -5,13 +5,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cloudreve
-PKG_VERSION:=3.7.1
+PKG_VERSION:=3.8.0
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/cloudreve/Cloudreve.git
PKG_SOURCE_VERSION:=$(PKG_VERSION)
-PKG_MIRROR_HASH:=b70601111e727d879a709884bc28237861216b99abac02b6f542f5984ddd8c0d
+PKG_MIRROR_HASH:=4c05afb2193ab83bf144d75963f4757c1445317e68b2690727375a8e01f7ba3d
PKG_LICENSE:=GPL-3.0-only
PKG_LICENSE_FILES:=LICENSE
@@ -35,7 +35,7 @@ define Package/cloudreve
SUBMENU:=Cloud Manager
TITLE:=A project helps you build your own cloud in minutes
URL:=https://cloudreve.org
- DEPENDS:=@(aarch64||arm||i386||i686||x86_64) +ca-bundle
+ DEPENDS:=@(aarch64||arm||i386||i686||riscv64||x86_64) +ca-bundle
endef
define Package/cloudreve/description
@@ -48,6 +48,8 @@ define Build/Compile
pushd $(PKG_BUILD_DIR)/assets ; \
yarn install ; \
yarn run build ; \
+ cd .. ; \
+ zip -r - assets/build > assets.zip ; \
popd ; \
$(call GoPackage/Build/Compile) ; \
)