aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-06-08 13:45:58 -0700
committerGitHub <noreply@github.com>2020-06-08 13:45:58 -0700
commit2796ced1b22e1e65794e8ac09f84b5473ee56d23 (patch)
treeba636919feb531b04379b29fe590e8eddaf515f0
parentbad7a80a7e05e0a4429b6a66805ee54eb14f05e5 (diff)
parentd69b0091c00f4402354ce6689ba260af6acb15c2 (diff)
Merge pull request #11363 from jmarcet/docker-compose_1_3
Docker compose (1 of 3)
-rw-r--r--lang/python/python-cached-property/Makefile36
-rw-r--r--lang/python/python-docopt/Makefile36
-rw-r--r--lang/python/python-texttable/Makefile34
-rw-r--r--lang/python/python-websocket-client/Makefile37
4 files changed, 143 insertions, 0 deletions
diff --git a/lang/python/python-cached-property/Makefile b/lang/python/python-cached-property/Makefile
new file mode 100644
index 000000000..447b4054c
--- /dev/null
+++ b/lang/python/python-cached-property/Makefile
@@ -0,0 +1,36 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-cached-property
+PKG_VERSION:=1.5.1
+PKG_RELEASE:=1
+
+PYPI_NAME:=cached-property
+PKG_HASH:=9217a59f14a5682da7c4b8829deadbfc194ac22e9908ccf7c8820234e80a1504
+
+PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+PYTHON3_PKG_SETUP_ARGS:=
+
+define Package/python3-cached-property
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=A decorator for caching properties in classes
+ URL:=https://github.com/pydanny/cached-property
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-cached-property/description
+ A decorator for caching properties in classes.
+endef
+
+$(eval $(call Py3Package,python3-cached-property))
+$(eval $(call BuildPackage,python3-cached-property))
+$(eval $(call BuildPackage,python3-cached-property-src))
diff --git a/lang/python/python-docopt/Makefile b/lang/python/python-docopt/Makefile
new file mode 100644
index 000000000..f4c96c537
--- /dev/null
+++ b/lang/python/python-docopt/Makefile
@@ -0,0 +1,36 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-docopt
+PKG_VERSION:=0.6.2
+PKG_RELEASE:=1
+
+PYPI_NAME:=docopt
+PKG_HASH:=49b3a825280bd66b3aa83585ef59c4a8c82f2c8a522dbe754a8bc8d08c85c491
+
+PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE-MIT
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+PYTHON3_PKG_SETUP_ARGS:=
+
+define Package/python3-docopt
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Pythonic argument parser, that will make you smile
+ URL:=http://docopt.org/
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-docopt/description
+ Pythonic argument parser, that will make you smile
+endef
+
+$(eval $(call Py3Package,python3-docopt))
+$(eval $(call BuildPackage,python3-docopt))
+$(eval $(call BuildPackage,python3-docopt-src))
diff --git a/lang/python/python-texttable/Makefile b/lang/python/python-texttable/Makefile
new file mode 100644
index 000000000..960061888
--- /dev/null
+++ b/lang/python/python-texttable/Makefile
@@ -0,0 +1,34 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-texttable
+PKG_VERSION:=1.6.2
+PKG_RELEASE:=1
+
+PYPI_NAME:=texttable
+PKG_HASH:=eff3703781fbc7750125f50e10f001195174f13825a92a45e9403037d539b4f4
+
+PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-texttable
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Module for creating simple ASCII tables
+ URL:=https://github.com/foutaise/texttable/
+ DEPENDS:=+python3-light +python3-codecs
+ VARIANT:=python3
+endef
+
+define Package/python3-texttable/description
+ Module for creating simple ASCII tables
+endef
+
+$(eval $(call Py3Package,python3-texttable))
+$(eval $(call BuildPackage,python3-texttable))
+$(eval $(call BuildPackage,python3-texttable-src))
diff --git a/lang/python/python-websocket-client/Makefile b/lang/python/python-websocket-client/Makefile
new file mode 100644
index 000000000..26381f865
--- /dev/null
+++ b/lang/python/python-websocket-client/Makefile
@@ -0,0 +1,37 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-websocket-client
+PKG_VERSION:=0.57.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=websocket_client
+PKG_HASH:=d735b91d6d1692a6a181f2a8c9e0238e5f6373356f561bb9dc4c7af36f452010
+
+PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-websocket-client
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=WebSocket client for Python. hybi13 is supported
+ URL:=https://github.com/websocket-client/websocket-client
+ DEPENDS:=+python3-light +python3-logging +python3-openssl +python3-six
+ VARIANT:=python3
+endef
+
+define Package/python3-websocket-client/description
+ websocket-client module is WebSocket client for python. This provide the low
+ level APIs for WebSocket. All APIs are the synchronous functions.
+
+ websocket-client supports only hybi-13.
+endef
+
+$(eval $(call Py3Package,python3-websocket-client))
+$(eval $(call BuildPackage,python3-websocket-client))
+$(eval $(call BuildPackage,python3-websocket-client-src))