aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-02-08 20:20:38 -0800
committerAlexander Couzens <lynxis@fe80.eu>2019-03-07 16:13:38 +0100
commit25f8cf0081e63efe4faad5bf9449d540579f2ef3 (patch)
tree687541201b1ed35dd31968ae7496e613af35df1b
parentceb39d08a06a506bff1e92b2e32e11dd1ed8824e (diff)
vips: Add Debian's reproducible build patch
Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--libs/vips/Makefile2
-rw-r--r--libs/vips/patches/010-reproducible-build.patch20
2 files changed, 21 insertions, 1 deletions
diff --git a/libs/vips/Makefile b/libs/vips/Makefile
index b1f55baea..fd4507d74 100644
--- a/libs/vips/Makefile
+++ b/libs/vips/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=vips
PKG_VERSION:=8.7.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/libvips/libvips/releases/download/v$(PKG_VERSION)
diff --git a/libs/vips/patches/010-reproducible-build.patch b/libs/vips/patches/010-reproducible-build.patch
new file mode 100644
index 000000000..54ef6c116
--- /dev/null
+++ b/libs/vips/patches/010-reproducible-build.patch
@@ -0,0 +1,20 @@
+Description: Make the build reproducible
+Author: Chris Lamb <lamby@debian.org>
+Reviewed-By: Laszlo Boszormenyi (GCS) <gcs@debian.org>
+Last-Update: 2018-07-24
+
+--- vips-8.6.4.orig/configure.ac
++++ vips-8.6.4/configure.ac
+@@ -26,7 +26,11 @@ VIPS_MAJOR_VERSION=vips_major_version()
+ VIPS_MINOR_VERSION=vips_minor_version()
+ VIPS_MICRO_VERSION=vips_micro_version()
+ VIPS_VERSION=vips_version()
+-VIPS_VERSION_STRING=$VIPS_VERSION-`date -u -r ChangeLog`
++if test "x$SOURCE_DATE_EPOCH" = "x"; then
++ VIPS_VERSION_STRING=$VIPS_VERSION-`date -u -r ChangeLog`
++else
++ VIPS_VERSION_STRING=$VIPS_VERSION-`LC_ALL=C date --utc --date="@$SOURCE_DATE_EPOCH"`
++fi
+
+ # libtool library versioning ... not user-visible (except as part of the
+ # library file name) and does not correspond to major/minor/micro above