aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorchamptar <champetier.etienne@gmail.com>2016-06-17 15:42:23 +0300
committerGitHub <noreply@github.com>2016-06-17 15:42:23 +0300
commit25af3a663247772c7c1ca41fd94da8af59624a1c (patch)
treedafb7e27a4fd2e6296f1657aa8d70a21876c7e90
parent5731b8e09b6992c4d387039eb2726331588274bb (diff)
parentb6d1ef53c3eabfb36c37298a9ff7a5730fe37045 (diff)
Merge pull request #2865 from miska/lxc-luci-features
Little improvement to LXC LuCI app
-rw-r--r--utils/luci-app-lxc/Makefile2
-rw-r--r--utils/luci-app-lxc/files/controller/lxc.lua34
-rw-r--r--utils/luci-app-lxc/files/view/lxc.htm19
3 files changed, 51 insertions, 4 deletions
diff --git a/utils/luci-app-lxc/Makefile b/utils/luci-app-lxc/Makefile
index f08d81e13..210f030a1 100644
--- a/utils/luci-app-lxc/Makefile
+++ b/utils/luci-app-lxc/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=luci-app-lxc
-PKG_RELEASE:=20141012
+PKG_RELEASE:=20160616
PKG_LICENSE:=Apache-2.0
diff --git a/utils/luci-app-lxc/files/controller/lxc.lua b/utils/luci-app-lxc/files/controller/lxc.lua
index de4fa9ff5..ea7adbafb 100644
--- a/utils/luci-app-lxc/files/controller/lxc.lua
+++ b/utils/luci-app-lxc/files/controller/lxc.lua
@@ -59,6 +59,9 @@ function index()
page = entry({"admin", "services", "lxc_action"}, call("lxc_action"), nil)
page.leaf = true
+ page = entry({"admin", "services", "lxc_get_downloadable"}, call("lxc_get_downloadable"), nil)
+ page.leaf = true
+
page = entry({"admin", "services", "lxc_configuration_get"}, call("lxc_configuration_get"), nil)
page.leaf = true
@@ -67,6 +70,27 @@ function index()
end
+function lxc_get_downloadable()
+ luci.http.prepare_content("application/json")
+
+ local f = io.popen('uname -m', 'r')
+ local target = f:read('*a')
+ f:close()
+ target = target:gsub("^%s*(.-)%s*$", "%1")
+
+ local templates = {}
+
+ local f = io.popen('lxc-create -n just_want_to_list_available_lxc_templates -t download -- --list', 'r')
+
+ for line in f:lines() do
+ local dist,version = line:match("^(%S+)%s+(%S+)%s+" .. target .. "%s+default%s+%S+$")
+ if dist~=nil and version~=nil then templates[#templates + 1] = dist .. ":" .. version end
+ end
+
+ f:close()
+ luci.http.write_json(templates)
+end
+
function lxc_create(lxc_name, lxc_template)
luci.http.prepare_content("text/plain")
@@ -78,9 +102,15 @@ function lxc_create(lxc_name, lxc_template)
return luci.http.write("1")
end
- local target = _G.DISTRIB_TARGET:match('([^/]+)')
+ local f = io.popen('uname -m', 'r')
+ local target = f:read('*a')
+ f:close()
+ target = target:gsub("^%s*(.-)%s*$", "%1")
+
+ local lxc_dist = lxc_template:gsub("(.*):(.*)", '%1')
+ local lxc_release = lxc_template:gsub("(.*):(.*)", '%2')
- local data = conn:call("lxc", "create", { name = lxc_name, template = "download", args = { "--server", url, "--no-validate", "--dist", lxc_template, "--release", "bb", "--arch", target } } )
+ local data = conn:call("lxc", "create", { name = lxc_name, template = "download", args = { "--server", url, "--no-validate", "--dist", lxc_dist, "--release", lxc_release, "--arch", target } } )
luci.http.write(data)
end
diff --git a/utils/luci-app-lxc/files/view/lxc.htm b/utils/luci-app-lxc/files/view/lxc.htm
index 1376968e3..bc767f366 100644
--- a/utils/luci-app-lxc/files/view/lxc.htm
+++ b/utils/luci-app-lxc/files/view/lxc.htm
@@ -47,7 +47,6 @@ Author: Petar Koretic <petar.koretic@sartura.hr>
</td>
<td>
<select id="s_template" class="cbi-input-select cbi-button">
- <option value="openwrt">OpenWrt</option>
</select>
</td>
<td>
@@ -438,4 +437,22 @@ Author: Petar Koretic <petar.koretic@sartura.hr>
}
lxc_list_update()
+
+ new XHR().get('<%=luci.dispatcher.build_url("admin", "services")%>/lxc_get_downloadable', null,
+ function(x, data)
+ {
+ if (!x) return;
+
+ var lxc_count = Object.keys(data).length
+ if (!data || !lxc_count) return;
+ var select = document.getElementById("s_template");
+ for(var key in data)
+ {
+ var option = document.createElement('option');
+ option.value = data[key];
+ option.text = data[key].replace(/[_:]/, ' ');
+ select.add(option, -1);
+ }
+ })
+
//]]></script>