aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Blake <chris@servernetworktech.com>2017-01-13 11:32:30 -0600
committerGitHub <noreply@github.com>2017-01-13 11:32:30 -0600
commit2568b67875dc2a5d16453a29595a2150d648cc96 (patch)
tree8ca8ab5828bbc8939e8705eca0d586cdd232913c
parentae19abe3305edfd8d8fd086f157c96e6450e5e40 (diff)
util/beep: Add beep package
This adds the beep utility, which allows users to control a pc speaker device. Maintainer: me / @riptidewave93 Compile tested: x86/64, LEDE Reboot SNAPSHOT r2709-b7677f0 Run tested: x86/64, LEDE Reboot SNAPSHOT r2709-b7677f0. Verify program works. Signed-off-by: Chris Blake <chrisrblake93@gmail.com>
-rw-r--r--utils/beep/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/utils/beep/Makefile b/utils/beep/Makefile
new file mode 100644
index 000000000..b59614fb5
--- /dev/null
+++ b/utils/beep/Makefile
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2017 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=beep
+PKG_REV:=0d790fa45777896749a885c3b93b2c1476d59f20
+PKG_VERSION:=1.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://github.com/johnath/beep.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+
+PKG_LICENSE:=GPL
+PKG_LICENSE_FILES:=
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/beep
+ SECTION:=sound
+ CATEGORY:=Sound
+ DEPENDS:=+kmod-pcspkr
+ TITLE:=Play beep sounds through a PC speaker
+ URL:=http://johnath.com/beep/README
+endef
+
+define Package/beep/description
+ This program plays beeps through the PC speaker
+endef
+
+CONFIGURE_ARGS += \
+ --enable-static \
+ --enable-shared
+
+MAKE_FLAGS += \
+ CFLAGS="$(TARGET_CFLAGS)"
+
+define Package/beep/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/beep $(1)/usr/bin
+endef
+
+$(eval $(call BuildPackage,beep))