aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Syam <privasisource@gmail.com>2023-12-01 19:01:52 +0800
committerRosen Penev <rosenp@gmail.com>2023-12-01 11:18:10 -0800
commit24847159857ccd64d5d823d109a03b1908b25bd0 (patch)
tree6b3d4069fffe01b1a6c4ea8cab5cd8e21b2db4ab
parent2dd3b1b17740740096539dfc88be80e2e7bedcba (diff)
perl: update to version 5.38.2
removed one that no longer exists in perl-5.38.2 updated one patch fixed missing builtin.pm Signed-off-by: Andy Syam <privasisource@gmail.com>
-rw-r--r--lang/perl/Makefile2
-rw-r--r--lang/perl/files/version.config2
-rw-r--r--lang/perl/patches/900-use-rm-force.patch9
-rw-r--r--lang/perl/perlbase.mk18
-rw-r--r--lang/perl/perlver.mk2
5 files changed, 15 insertions, 18 deletions
diff --git a/lang/perl/Makefile b/lang/perl/Makefile
index 5249a0505..afd82997f 100644
--- a/lang/perl/Makefile
+++ b/lang/perl/Makefile
@@ -15,7 +15,7 @@ PKG_RELEASE:=1
PKG_SOURCE_URL:=https://www.cpan.org/src/5.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_HASH:=eca551caec3bc549a4e590c0015003790bdd1a604ffe19cc78ee631d51f7072e
+PKG_HASH:=d91115e90b896520e83d4de6b52f8254ef2b70a8d545ffab33200ea9f1cf29e8
PKG_LICENSE:=GPL-1.0-or-later Artistic-1.0-Perl
PKG_LICENSE_FILES:=Copying Artistic README
diff --git a/lang/perl/files/version.config b/lang/perl/files/version.config
index fbd036130..1c0e7718c 100644
--- a/lang/perl/files/version.config
+++ b/lang/perl/files/version.config
@@ -1,7 +1,7 @@
# Set the version here
PERL_REVISION=5
PERL_VERSION=38
-PERL_SUBVERSION=0
+PERL_SUBVERSION=2
# (api_revison, api_version, api_subversion) = (revision, version, 0) usually
PERL_API_REVISION=5
diff --git a/lang/perl/patches/900-use-rm-force.patch b/lang/perl/patches/900-use-rm-force.patch
index 857cd1e9e..09967bebd 100644
--- a/lang/perl/patches/900-use-rm-force.patch
+++ b/lang/perl/patches/900-use-rm-force.patch
@@ -120,8 +120,8 @@
!NO!SUBS!
case "$osname" in
-@@ -1133,8 +1134,8 @@ pod/perl5380delta.pod: pod/perldelta.pod
- $(LNS) perldelta.pod pod/perl5380delta.pod
+@@ -1133,8 +1134,8 @@ pod/perl5382delta.pod: pod/perldelta.pod
+ $(LNS) perldelta.pod pod/perl5382delta.pod
extra.pods: $(MINIPERL_EXE)
- -@test ! -f extra.pods || rm -f `cat extra.pods`
@@ -153,14 +153,14 @@
# Like distclean but also removes emacs backups and *.orig.
veryclean: _verycleaner _mopup _clobber
- -@rm -f Obsolete Wanted
-+ $(RMS) Obsolete Wanted
++ @$(RMS) Obsolete Wanted
# Do not 'make _mopup' directly.
_mopup:
- rm -f *$(OBJ_EXT) *$(LIB_EXT) all perlmain.c $(mini_only_src) generate_uudmap$(EXE_EXT) $(generated_headers)
+ $(RMS) *$(OBJ_EXT) *$(LIB_EXT) all perlmain.c $(mini_only_src) generate_uudmap$(EXE_EXT) $(generated_headers)
-rmdir .depending
-- -rm *.depends makedepend_file
+ -rm *.depends makedepend_file
- -@test -f extra.pods && rm -f `cat extra.pods`
- -@test -f vms/README_vms.pod && rm -f vms/README_vms.pod
- -rm -f perl.exp ext.libs $(generated_pods) uni.data $(mini_only_objs) pod/roffitall
@@ -169,7 +169,6 @@
- -rm -f cygwin.c libperl*.def libperl*.dll cygperl*.dll *.exe.stackdump
- -rm -f $(PERL_EXE) $(MINIPERL_EXE) $(LIBPERL) libperl.* microperl
- -rm -f config.arch config.over $(DTRACE_H)
-+ $(RMS) *.depends makedepend_file
+ -@test -f extra.pods && $(RMS) `cat extra.pods`
+ -@test -f vms/README_vms.pod && $(RMS) vms/README_vms.pod
+ $(RMS) perl.exp ext.libs $(generated_pods) uni.data $(mini_only_objs) pod/roffitall
diff --git a/lang/perl/perlbase.mk b/lang/perl/perlbase.mk
index f3d65a517..c50fda1b1 100644
--- a/lang/perl/perlbase.mk
+++ b/lang/perl/perlbase.mk
@@ -140,7 +140,7 @@ endef
define Package/perlbase-b/install
$(call perlmod/Install,$(1),B B.pm auto/B,)
-$(call perlmod/InstallBaseTests,$(1),cpan/B-Debug/t ext/B/t lib/B/Deparse-core.t lib/B/Deparse-subclass.t lib/B/Deparse.t)
+$(call perlmod/InstallBaseTests,$(1),ext/B/t lib/B/Deparse-core.t lib/B/Deparse-subclass.t lib/B/Deparse.t)
endef
$(eval $(call BuildPackage,perlbase-b))
@@ -405,7 +405,6 @@ endef
define Package/perlbase-digest/install
$(call perlmod/Install,$(1),Digest Digest.pm auto/Digest,)
$(call perlmod/InstallBaseTests,$(1),cpan/Digest-MD5/MD5.xs cpan/Digest-MD5/t cpan/Digest-SHA/t cpan/Digest/t)
- $(INSTALL_DIR) $(1)/$(PERL_TESTSDIR)/cpan/Digest-SHA/src
endef
$(eval $(call BuildPackage,perlbase-digest))
@@ -543,9 +542,9 @@ DEPENDS+=+perlbase-config
endef
define Package/perlbase-essential/install
-$(call perlmod/Install,$(1),Carp Carp.pm Exporter Exporter.pm constant.pm deprecate.pm lib.pm locale.pm overload.pm overloading.pm parent.pm strict.pm subs.pm vars.pm warnings warnings.pm,)
+$(call perlmod/Install,$(1),Carp Carp.pm Exporter Exporter.pm constant.pm deprecate.pm lib.pm builtin.pm locale.pm overload.pm overloading.pm parent.pm strict.pm subs.pm vars.pm vmsish.pm warnings warnings.pm,)
$(call perlmod/Install/NoStrip,$(1),overload/numbers.pm,)
-$(call perlmod/InstallBaseTests,$(1),cpan/parent/t dist/Carp/t dist/Exporter/t dist/constant/t dist/lib/t lib/locale.t lib/overload.t lib/overload64.t lib/overloading.t lib/strict.t lib/subs.t lib/vars.t lib/vars_carp.t lib/warnings.t)
+$(call perlmod/InstallBaseTests,$(1),cpan/parent/t dist/Carp/t dist/Exporter/t dist/constant/t dist/lib/t lib/builtin.t lib/locale.t lib/overload.t lib/overload64.t lib/overloading.t lib/strict.t lib/subs.t lib/vars.t lib/vars_carp.t lib/vmsish.t lib/warnings.t)
endef
$(eval $(call BuildPackage,perlbase-essential))
@@ -558,7 +557,7 @@ DEPENDS+=+perlbase-essential +perlbase-feature +perlbase-version
endef
define Package/perlbase-experimental/install
-$(call perlmod/Install,$(1),experimental.pm,)
+$(call perlmod/Install,$(1),experimental.pm stable.pm,)
$(call perlmod/InstallBaseTests,$(1),cpan/experimental/t)
endef
@@ -891,7 +890,7 @@ endef
define Package/perlbase-locale/install
$(call perlmod/Install,$(1),Locale,Locale/Constants.pod Locale/Country.pod Locale/Currency.pod Locale/Language.pod Locale/Maketext.pod Locale/Maketext/TPJ13.pod Locale/Script.pod)
-$(call perlmod/InstallBaseTests,$(1),cpan/Locale-Codes/t cpan/Locale-Maketext-Simple/t dist/Locale-Maketext/t)
+$(call perlmod/InstallBaseTests,$(1),cpan/Locale-Maketext-Simple/t dist/Locale-Maketext/t)
endef
$(eval $(call BuildPackage,perlbase-locale))
@@ -905,7 +904,7 @@ endef
define Package/perlbase-math/install
$(call perlmod/Install,$(1),Math auto/Math,)
-$(call perlmod/InstallBaseTests,$(1),cpan/Math-Complex/t cpan/Math-BigInt-FastCalc/t cpan/Math-BigInt/t cpan/Math-BigRat/t)
+$(call perlmod/InstallBaseTests,$(1),cpan/Math-BigInt-FastCalc/t cpan/Math-BigInt/t cpan/Math-BigRat/t)
endef
$(eval $(call BuildPackage,perlbase-math))
@@ -1128,7 +1127,7 @@ endef
define Package/perlbase-pod/install
$(call perlmod/Install,$(1),Pod,Pod/Usage.pm)
$(call perlmod/Install/NoStrip,$(1),Pod/Usage.pm,)
-$(call perlmod/InstallBaseTests,$(1),cpan/Pod-Checker/t cpan/Pod-Escapes/t cpan/Pod-Parser/lib cpan/Pod-Parser/scripts cpan/Pod-Parser/t cpan/Pod-Perldoc/t cpan/Pod-Simple/t cpan/Pod-Usage/scripts cpan/Pod-Usage/t cpan/podlators/t ext/Pod-Functions/Functions.pm ext/Pod-Functions/t ext/Pod-Html/t lib/Pod/t)
+$(call perlmod/InstallBaseTests,$(1),cpan/Pod-Checker/t cpan/Pod-Escapes/t cpan/Pod-Perldoc/t cpan/Pod-Simple/t cpan/Pod-Usage/scripts cpan/Pod-Usage/t cpan/podlators/t ext/Pod-Functions/Functions.pm ext/Pod-Functions/t ext/Pod-Html/t lib/Pod/t)
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/pod2man $(1)/usr/bin/
$(CP) $(PKG_INSTALL_DIR)/usr/bin/pod2text $(1)/usr/bin/
@@ -1188,7 +1187,6 @@ endef
define Package/perlbase-scalar/install
$(call perlmod/Install,$(1),Scalar Sub,)
$(call perlmod/InstallBaseTests,$(1),cpan/Scalar-List-Utils/t)
- $(INSTALL_DIR) $(1)/$(PERL_TESTSDIR)/cpan/Scalar-List-Utils/blib
endef
$(eval $(call BuildPackage,perlbase-scalar))
@@ -1368,7 +1366,7 @@ DEPENDS+=+perlbase-base +perlbase-config +perlbase-essential +perlbase-io +perlb
endef
define Package/perlbase-test/install
-$(call perlmod/Install,$(1),Test Test.pm ok.pm,Test/Builder.pm Test/Harness/TAP.pod Test/More.pm Test/Tutorial.pod)
+$(call perlmod/Install,$(1),Test Test2 Test.pm Test2.pm ok.pm,Test/Builder.pm Test/More.pm Test/Tutorial.pod Test2/Transition.pod)
$(call perlmod/Install/NoStrip,$(1),Test/Builder.pm Test/More.pm,)
$(call perlmod/InstallBaseTests,$(1),cpan/Test-Harness/t cpan/Test-Simple/t dist/Test/t)
$(INSTALL_DIR) $(1)/usr/bin
diff --git a/lang/perl/perlver.mk b/lang/perl/perlver.mk
index 465140bf1..b0acc5d9e 100644
--- a/lang/perl/perlver.mk
+++ b/lang/perl/perlver.mk
@@ -1,4 +1,4 @@
-PERL_VERSION:=5.38.0
+PERL_VERSION:=5.38.2
PERL_EXPLODE:=$(subst ., ,$(PERL_VERSION))