aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-11-17 21:56:10 -0800
committerRosen Penev <rosenp@gmail.com>2020-11-24 22:41:22 -0800
commit242afe6d3e1be57a4b33fec8cf510f386e33d235 (patch)
tree80c11fda170b145314b02c9a1e462cfdcae45462
parent1d3c84d4e65e1fb20645be58f49a4ac068f1e96c (diff)
meson: update to 0.56.0
Move c/c++ options from properties to built-in options as there is now a deprecated warning. Remove cross libdir value. It's default since version 0.50. Remove ld option as it was removed in version 0.51. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--devel/meson/Makefile4
-rw-r--r--devel/meson/meson.mk1
-rw-r--r--devel/meson/src/openwrt-cross.txt.in8
-rw-r--r--devel/meson/src/openwrt-native.txt.in2
4 files changed, 7 insertions, 8 deletions
diff --git a/devel/meson/Makefile b/devel/meson/Makefile
index 6a26da73b..68b8093c3 100644
--- a/devel/meson/Makefile
+++ b/devel/meson/Makefile
@@ -1,11 +1,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=meson
-PKG_VERSION:=0.55.3
+PKG_VERSION:=0.56.0
PKG_RELEASE:=1
PYPI_NAME:=meson
-PKG_HASH:=6bed2a25a128bbabe97cf40f63165ebe800e4fcb46db8ab7ef5c2b5789f092a5
+PKG_HASH:=291dd38ff1cd55fcfca8fc985181dd39be0d3e5826e5f0013bf867be40117213
PKG_MAINTAINER:=Andre Heider <a.heider@gmail.com>
PKG_LICENSE:=Apache-2.0
diff --git a/devel/meson/meson.mk b/devel/meson/meson.mk
index b3364a19e..b855e267d 100644
--- a/devel/meson/meson.mk
+++ b/devel/meson/meson.mk
@@ -76,7 +76,6 @@ define Meson/CreateCrossFile
-e "s|@AR@|$(TARGET_AR)|" \
-e "s|@STRIP@|$(TARGET_CROSS)strip|" \
-e "s|@NM@|$(TARGET_NM)|" \
- -e "s|@LD@|$(TARGET_CROSS)ld|" \
-e "s|@PKGCONFIG@|$(PKG_CONFIG)|" \
-e "s|@CFLAGS@|$(foreach FLAG,$(TARGET_CFLAGS) $(EXTRA_CFLAGS) $(TARGET_CPPFLAGS) $(EXTRA_CPPFLAGS),'$(FLAG)',)|" \
-e "s|@CXXFLAGS@|$(foreach FLAG,$(TARGET_CXXFLAGS) $(EXTRA_CXXFLAGS) $(TARGET_CPPFLAGS) $(EXTRA_CPPFLAGS),'$(FLAG)',)|" \
diff --git a/devel/meson/src/openwrt-cross.txt.in b/devel/meson/src/openwrt-cross.txt.in
index f8c2db9dc..32e4ca48d 100644
--- a/devel/meson/src/openwrt-cross.txt.in
+++ b/devel/meson/src/openwrt-cross.txt.in
@@ -4,15 +4,13 @@ cpp = [@CXX@]
ar = '@AR@'
strip = '@STRIP@'
nm = '@NM@'
-ld = '@LD@'
pkgconfig = '@PKGCONFIG@'
-[properties]
+[built-in options]
c_args = [@CFLAGS@]
c_link_args = [@LDFLAGS@]
cpp_args = [@CXXFLAGS@]
cpp_link_args = [@LDFLAGS@]
-needs_exe_wrapper = true
[host_machine]
system = 'linux'
@@ -20,6 +18,8 @@ cpu_family = '@ARCH@'
cpu = '@CPU@'
endian = '@ENDIAN@'
+[properties]
+needs_exe_wrapper = true
+
[paths]
prefix = '/usr'
-libdir = 'lib'
diff --git a/devel/meson/src/openwrt-native.txt.in b/devel/meson/src/openwrt-native.txt.in
index e5d5a2617..601edfbc4 100644
--- a/devel/meson/src/openwrt-native.txt.in
+++ b/devel/meson/src/openwrt-native.txt.in
@@ -3,7 +3,7 @@ c = [@CC@]
cpp = [@CXX@]
pkgconfig = '@PKGCONFIG@'
-[properties]
+[built-in options]
c_args = [@CFLAGS@]
c_link_args = [@LDFLAGS@]
cpp_args = [@CXXFLAGS@]