aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2019-04-23 11:16:08 +0300
committerGitHub <noreply@github.com>2019-04-23 11:16:08 +0300
commit23dcc7293594d7a01156433f667ac8aa05dadd64 (patch)
tree5396c308c2ef39f7d6a9e2713f13304a7a6bd769
parentade64229559f073f79006a68248388fd5de24192 (diff)
parent9fb2d52191d214b58e08c098de0feec393dddfe1 (diff)
Merge pull request #8727 from jefferyto/python-twisted-19.2.0
python-twisted: Update to 19.2.0, refresh patches
-rw-r--r--lang/python/python-twisted/Makefile6
-rw-r--r--lang/python/python-twisted/patches/001-omit-tkconch.patch2
-rw-r--r--lang/python/python-twisted/patches/002-omit-tests.patch12
3 files changed, 10 insertions, 10 deletions
diff --git a/lang/python/python-twisted/Makefile b/lang/python/python-twisted/Makefile
index 7f50c5204..d9f81091c 100644
--- a/lang/python/python-twisted/Makefile
+++ b/lang/python/python-twisted/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-twisted
-PKG_VERSION:=18.9.0
-PKG_RELEASE:=4
+PKG_VERSION:=19.2.0
+PKG_RELEASE:=1
PKG_SOURCE:=Twisted-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/T/Twisted
-PKG_HASH:=294be2c6bf84ae776df2fc98e7af7d6537e1c5e60a46d33c3ce2a197677da395
+PKG_HASH:=1708e1928ae84ec9d3ebab0d427e20e1e38ff721b15bbced476d047d4a43abbe
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-twisted-$(PKG_VERSION)
PKG_BUILD_DEPENDS:=libtirpc
diff --git a/lang/python/python-twisted/patches/001-omit-tkconch.patch b/lang/python/python-twisted/patches/001-omit-tkconch.patch
index 1ec4baf0f..a5bddaaec 100644
--- a/lang/python/python-twisted/patches/001-omit-tkconch.patch
+++ b/lang/python/python-twisted/patches/001-omit-tkconch.patch
@@ -1,6 +1,6 @@
--- a/src/twisted/python/_setup.py
+++ b/src/twisted/python/_setup.py
-@@ -144,7 +144,6 @@ _CONSOLE_SCRIPTS = [
+@@ -147,7 +147,6 @@ _CONSOLE_SCRIPTS = [
"conch = twisted.conch.scripts.conch:run",
"mailmail = twisted.mail.scripts.mailmail:run",
"pyhtmlizer = twisted.scripts.htmlizer:run",
diff --git a/lang/python/python-twisted/patches/002-omit-tests.patch b/lang/python/python-twisted/patches/002-omit-tests.patch
index 33ba77a0f..83ca2cd76 100644
--- a/lang/python/python-twisted/patches/002-omit-tests.patch
+++ b/lang/python/python-twisted/patches/002-omit-tests.patch
@@ -1,18 +1,18 @@
--- a/src/twisted/python/_setup.py
+++ b/src/twisted/python/_setup.py
-@@ -169,11 +169,6 @@ class ConditionalExtension(Extension, object):
-
+@@ -173,11 +173,6 @@ class ConditionalExtension(Extension, ob
# The C extensions used for Twisted.
_EXTENSIONS = [
-- ConditionalExtension(
+ ConditionalExtension(
- "twisted.test.raiser",
- sources=["src/twisted/test/raiser.c"],
- condition=lambda _: _isCPython),
-
- ConditionalExtension(
+- ConditionalExtension(
"twisted.internet.iocpreactor.iocpsupport",
sources=[
-@@ -238,12 +233,11 @@ def getSetupArgs(extensions=_EXTENSIONS):
+ "src/twisted/internet/iocpreactor/iocpsupport/iocpsupport.c",
+@@ -241,12 +236,11 @@ def getSetupArgs(extensions=_EXTENSIONS)
"incremental >= 16.10.1",
"Automat >= 0.3.0",
"hyperlink >= 17.1.1",
@@ -26,7 +26,7 @@
use_incremental=True,
setup_requires=["incremental >= 16.10.1"],
install_requires=requirements,
-@@ -253,7 +247,7 @@ def getSetupArgs(extensions=_EXTENSIONS):
+@@ -256,7 +250,7 @@ def getSetupArgs(extensions=_EXTENSIONS)
cmdclass=command_classes,
include_package_data=True,
exclude_package_data={