aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-02 13:30:29 +0200
committerJohn Crispin <blogic@openwrt.org>2015-10-19 12:20:10 +0200
commit23bee2145ff377b48d3e49613f93b3b8c7a82dda (patch)
tree8285542a116fbdbb97375041e78e993c1374c209
parent79cfbb8edf0844b934ae9c3244c6bb57f89934cf (diff)
swig: add host build
this is a binding generator needed to build node plugins Signed-off-by: John Crispin <blogic@openwrt.org>
-rw-r--r--utils/swig/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/utils/swig/Makefile b/utils/swig/Makefile
new file mode 100644
index 000000000..c74bdb89c
--- /dev/null
+++ b/utils/swig/Makefile
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=swig
+PKG_VERSION:=3.0.7
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=7fff46c84b8c630ede5b0f0827e3d90a
+PKG_INSTALL:=1
+
+PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
+PKG_LICENSE:=GPL-3.0
+
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/package.mk
+
+define Package/swig
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=swig binding generator
+ BUILDONLY:=1
+endef
+
+define Package/swig/description
+ tool that generates bindings for various languages
+endef
+
+$(eval $(call HostBuild))
+$(eval $(call BuildPackage,swig))