aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-09-19 14:31:20 -0700
committerGitHub <noreply@github.com>2020-09-19 14:31:20 -0700
commit221cdc852400bf6dbeda1f170355dd4d0a2471fb (patch)
tree20158a9fd108e16ba1b9f89a7b8973acf9510e97
parent7d1cc2dbd353429b0485efb66e626cc798b75cac (diff)
parentda840fa878b036ade4e527a1f5522919168b892d (diff)
Merge pull request #13427 from neheb/booo
boost: replace zstd dependency with libzstd
-rw-r--r--libs/boost/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index c8da7f5dc..b8b8f9ef7 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -13,7 +13,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=boost
PKG_VERSION:=1.74.0
PKG_SOURCE_VERSION:=1_74_0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://dl.bintray.com/boostorg/release/$(PKG_VERSION)/source/
@@ -336,7 +336,7 @@ $(eval $(call DefineBoostLibrary,date_time))
$(eval $(call DefineBoostLibrary,fiber,coroutine filesystem,,!boost-fiber-exclude))
$(eval $(call DefineBoostLibrary,filesystem,system))
$(eval $(call DefineBoostLibrary,graph,regex))
-$(eval $(call DefineBoostLibrary,iostreams,,+zlib +liblzma +libbz2 +zstd))
+$(eval $(call DefineBoostLibrary,iostreams,,+zlib +liblzma +libbz2 +libzstd))
$(eval $(call DefineBoostLibrary,locale,system,$(ICONV_DEPENDS),BUILD_NLS))
$(eval $(call DefineBoostLibrary,log,system chrono date_time thread filesystem regex))
$(eval $(call DefineBoostLibrary,math))