aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-11-25 14:22:05 -0800
committerGitHub <noreply@github.com>2020-11-25 14:22:05 -0800
commit21e96c8875a5d6174aef55a4f1e2b3ce358dbba6 (patch)
tree87541569dcbdab41c02fbeb490bc88d2b59fdf4b
parent24487afe1f1f9ec7ec87166147f6c90bef892cae (diff)
parent22ec02167f1f267ddad3e458a43312f7403cec09 (diff)
Merge pull request #13987 from neheb/onig
oniguruma: update to 6.9.6
-rw-r--r--libs/oniguruma/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/libs/oniguruma/Makefile b/libs/oniguruma/Makefile
index 62b325ee8..4ff3a662f 100644
--- a/libs/oniguruma/Makefile
+++ b/libs/oniguruma/Makefile
@@ -5,25 +5,24 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=oniguruma
-PKG_VERSION:=6.9.5_rev1
-PKG_RELEASE:=3
+PKG_VERSION:=6.9.6
+PKG_RELEASE:=1
PKG_SOURCE:=onig-v$(subst _,-,$(PKG_VERSION)).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/kkos/oniguruma/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=e0c2212102fa4146c43b6c4f2f7727a84fd055cc2109c293d64298cef0c372b5
+PKG_HASH:=aec9f6902ad8b7bb53b2c55d04686ea75da89a06694836b0362cb206578dfe89
PKG_MAINTAINER:=Eneas U de Queiroz <cotequeiroz@gmail.com>
PKG_LICENSE:=BSD-2-Clause
PKG_LICENSE_FILES:=COPYING
PKG_CPE_ID:=cpe:/a:oniguruma_project:oniguruma
-PKG_INSTALL:=1
PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
-CONFIGURE_ARGS += --enable-posix-api
-
define Package/oniguruma
SECTION:=libs
CATEGORY:=Libraries
@@ -40,6 +39,8 @@ define Package/oniguruma/description
Character encoding can be specified per regular expression object.
endef
+CONFIGURE_ARGS += --enable-posix-api
+
define Package/oniguruma/install
$(INSTALL_DIR) $(1)/usr/lib
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libonig.so.$(ABI_VERSION) $(1)/usr/lib/