aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHsing-Wang Liao <kuoruan@gmail.com>2017-02-19 21:38:55 +0800
committerHsing-Wang Liao <kuoruan@gmail.com>2017-02-19 22:48:00 +0800
commit20e9787ef9b6332eaa90daf8512bc26ff429f2e7 (patch)
treecdb73769243239e06d770e1ea06fbc37847ab859
parenta3d01ddf2999a40602c2084324fed6a4c4dfa11c (diff)
aria2: Add more feature choices and switch default XML parser library to Libxml2
Signed-off-by: Hsing-Wang Liao <kuoruan@gmail.com>
-rw-r--r--net/aria2/Config.in36
-rw-r--r--net/aria2/Makefile14
2 files changed, 30 insertions, 20 deletions
diff --git a/net/aria2/Config.in b/net/aria2/Config.in
index b0d7309d3..2f0443993 100644
--- a/net/aria2/Config.in
+++ b/net/aria2/Config.in
@@ -1,8 +1,8 @@
-menu "Aria2 configuration"
+menu "Aria2 Configuration"
depends on PACKAGE_aria2
choice
- prompt "SSL library"
+ prompt "SSL Library"
default ARIA2_OPENSSL
config ARIA2_OPENSSL
@@ -12,34 +12,42 @@ config ARIA2_GNUTLS
bool "GNUTLS"
config ARIA2_NOSSL
- bool "No SSL support"
+ bool "No SSL Support"
endchoice
config ARIA2_BITTORRENT
- bool "Enable bittorrent support"
+ bool "Enable Bittorrent Support"
depends on ARIA2_OPENSSL
default n
-config ARIA2_METALINK
- bool "Enable metalink support"
- default n
-
config ARIA2_SFTP
- bool "Enable sftp support"
+ bool "Enable SFTP Support"
default n
+config ARIA2_ASYNC_DNS
+ bool "Enable Async DNS Support"
+ default n
+
+config ARIA2_COOKIE
+ bool "Enable Firefox3/Chromium Cookie Support"
+ default n
+
+config ARIA2_METALINK
+ bool "Enable Metalink Support"
+ default n
+
choice
- prompt "XML library"
- default ARIA2_EXPAT
+ prompt "XML Library"
+ default ARIA2_LIBXML2
depends on ARIA2_METALINK
+config ARIA2_LIBXML2
+ bool "LIBXML2"
+
config ARIA2_EXPAT
bool "EXPAT"
-config ARIA2_LIBXML2
- bool "LIBXML2"
-
endchoice
endmenu
diff --git a/net/aria2/Makefile b/net/aria2/Makefile
index a96d4b86c..92a8e4a76 100644
--- a/net/aria2/Makefile
+++ b/net/aria2/Makefile
@@ -24,8 +24,10 @@ PKG_CONFIG_DEPENDS := \
ARIA2_OPENSSL \
ARIA2_GNUTLS \
ARIA2_BITTORRENT \
- ARIA2_METALINK \
ARIA2_SFTP \
+ ARIA2_ASYNC_DNS \
+ ARIA2_COOKIE \
+ ARIA2_METALINK \
ARIA2_EXPAT \
ARIA2_LIBXML2
@@ -41,7 +43,7 @@ define Package/aria2
SUBMENU:=File Transfer
TITLE:=lightweight download utility
URL:=https://aria2.github.io/
- DEPENDS:=+zlib +ARIA2_SFTP:libssh2 +ARIA2_LIBXML2:libxml2 +ARIA2_EXPAT:libexpat +libstdcpp +ARIA2_OPENSSL:libopenssl +ARIA2_GNUTLS:libgnutls
+ DEPENDS:=+zlib +libstdcpp +ARIA2_SFTP:libssh2 +ARIA2_ASYNC_DNS:libcares +ARIA2_COOKIE:libsqlite3 +ARIA2_LIBXML2:libxml2 +ARIA2_EXPAT:libexpat +ARIA2_OPENSSL:libopenssl +ARIA2_GNUTLS:libgnutls
endef
define Package/aria2/description
@@ -52,19 +54,19 @@ endef
CONFIGURE_ARGS += \
--disable-nls \
$(if $(CONFIG_ARIA2_NOSSL),--disable,--enable)-ssl \
- $(if $(CONFIG_ARIA2_OPENSSL),--with,--without)-openssl \
- $(if $(CONFIG_ARIA2_GNUTLS),--with,--without)-gnutls \
$(if $(CONFIG_ARIA2_BITTORRENT),--enable,--disable)-bittorrent \
$(if $(CONFIG_ARIA2_METALINK),--enable,--disable)-metalink \
+ $(if $(CONFIG_ARIA2_OPENSSL),--with,--without)-openssl \
+ $(if $(CONFIG_ARIA2_GNUTLS),--with,--without)-gnutls \
$(if $(CONFIG_ARIA2_SFTP),--with,--without)-libssh2 \
+ $(if $(CONFIG_ARIA2_ASYNC_DNS),--with,--without)-libcares \
+ $(if $(CONFIG_ARIA2_COOKIE),--with,--without)-sqlite3 \
$(if $(CONFIG_ARIA2_LIBXML2),--with,--without)-libxml2 \
$(if $(CONFIG_ARIA2_EXPAT),--with,--without)-libexpat \
--without-libnettle \
--without-libgmp \
--without-libgcrypt \
- --without-libcares \
--without-libuv \
- --without-sqlite3 \
--with-libz
define Package/aria2/install