aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-11-26 22:31:26 +0000
committerDaniel Golle <daniel@makrotopia.org>2020-12-20 19:09:43 +0000
commit20c52fc6516a76b90f516caa5a119860c0b605cc (patch)
tree099ba5bb010c0fa97cf9bf0ce64fb59cb98f8d20
parent3421545a2cbc4e835a7dc68be1d55753981deccc (diff)
transmission: jail: add allow 'getuid' syscall
transmission needs 'getuid', at least on mips_24kc. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
-rw-r--r--net/transmission/Makefile2
-rw-r--r--net/transmission/files/transmission-daemon.json1
2 files changed, 2 insertions, 1 deletions
diff --git a/net/transmission/Makefile b/net/transmission/Makefile
index 92e8aea55..28c106a0b 100644
--- a/net/transmission/Makefile
+++ b/net/transmission/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=transmission
PKG_VERSION:=3.00
-PKG_RELEASE:=8
+PKG_RELEASE:=9
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GITHUB/transmission/transmission-releases/master
diff --git a/net/transmission/files/transmission-daemon.json b/net/transmission/files/transmission-daemon.json
index 8e911e731..f869ac808 100644
--- a/net/transmission/files/transmission-daemon.json
+++ b/net/transmission/files/transmission-daemon.json
@@ -31,6 +31,7 @@
"getpid",
"getsockname",
"getsockopt",
+ "getuid",
"getuid32",
"ioctl",
"listen",