aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-06-25 18:36:54 -0700
committerGitHub <noreply@github.com>2020-06-25 18:36:54 -0700
commit1f813be5dfda24a1f82a1903e502952587bab012 (patch)
tree6b1ea59aa4439c6352f1c8be117add20a0485731
parentf10023094ee336eaf070e4cbb893bccfeb7f43b7 (diff)
parent2491bcf81b6c27ae898ab008b3ba8c5abe79d805 (diff)
Merge pull request #12612 from neheb/xfsp
xfsprogs: fix compilation with uClibc-ng
-rw-r--r--utils/xfsprogs/Makefile2
-rw-r--r--utils/xfsprogs/patches/140-mman.patch6
2 files changed, 6 insertions, 2 deletions
diff --git a/utils/xfsprogs/Makefile b/utils/xfsprogs/Makefile
index 335c8f711..c14960e5b 100644
--- a/utils/xfsprogs/Makefile
+++ b/utils/xfsprogs/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=xfsprogs
PKG_VERSION:=5.5.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/fs/xfs/xfsprogs
diff --git a/utils/xfsprogs/patches/140-mman.patch b/utils/xfsprogs/patches/140-mman.patch
index 936d3cc29..fef5d50a2 100644
--- a/utils/xfsprogs/patches/140-mman.patch
+++ b/utils/xfsprogs/patches/140-mman.patch
@@ -1,6 +1,6 @@
--- a/io/mmap.c
+++ b/io/mmap.c
-@@ -11,6 +11,10 @@
+@@ -11,6 +11,14 @@
#include "init.h"
#include "io.h"
@@ -8,6 +8,10 @@
+#define MAP_SYNC 0
+#endif
+
++#ifndef MAP_SHARED_VALIDATE
++#define MAP_SHARED_VALIDATE 0x03
++#endif
++
static cmdinfo_t mmap_cmd;
static cmdinfo_t mread_cmd;
static cmdinfo_t msync_cmd;