aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Malik <julien.malik@paraiso.me>2023-02-07 23:34:10 +0100
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2023-03-27 09:34:50 +0200
commit1f25be97b6c73691ec5a00a9deb9a7456e59be8c (patch)
treee4423e376eb72302777826f68a8ee9ed86355a5d
parent6b1df72e64628dbeb68a2b5fd2cfb68db87a2d2f (diff)
borgbackup: add missing dependencies
The initial package submission was missing some required and optional dependencies due to lack of testing on a system without any python related packages pre-installed. Some optional but highly recommended dependencies were discovered with the stdlib module as described in: https://github.com/openwrt/packages/blob/392a68e24774294590abf9c08ea1832f2cee190d/lang/python/README.md Fixes #20441 Signed-off-by: Julien Malik <julien.malik@paraiso.me>
-rw-r--r--lang/python/borgbackup/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/lang/python/borgbackup/Makefile b/lang/python/borgbackup/Makefile
index 0637d1b0b..09bf915af 100644
--- a/lang/python/borgbackup/Makefile
+++ b/lang/python/borgbackup/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2022 Julien Malik <julien.malik@paraiso.me>
+# Copyright (C) 2023 Julien Malik <julien.malik@paraiso.me>
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=borgbackup
PKG_VERSION:=1.2.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=borgbackup
PKG_HASH:=e32418f8633c96fa9681352a56eb63b98e294203472c114a5242709d36966785
@@ -22,6 +22,7 @@ include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk
+# see #20462 and #12942: email and urllib shall come with python3-light
define Package/borgbackup
SECTION:=lang
CATEGORY:=Languages
@@ -30,8 +31,17 @@ define Package/borgbackup
URL:=https://github.com/borgbackup/borg
DEPENDS:= \
+python3-light \
+ +python3-codecs \
+ +python3-email \
+ +python3-logging \
+ +python3-lzma \
+python3-msgpack \
+ +python3-packaging \
+python3-pyfuse3 \
+ +python3-readline \
+ +python3-unittest \
+ +python3-urllib \
+ +python3-uuid \
+libacl \
+libopenssl \
+liblz4 \