aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHirokazu MORIKAWA <morikw2@gmail.com>2019-04-19 09:22:23 +0900
committerHirokazu MORIKAWA <morikw2@gmail.com>2019-04-19 09:22:23 +0900
commit1ce1ca6e0622c6ad7fb61e44b7c96b028939186a (patch)
tree5bb47e416fbe3b140b08bf3cbfb9573dd2de329c
parente689372b376be3481e030080d8d39e467389cb4b (diff)
node-serialport: fix i386 build fail
more stability for parallel build Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
-rw-r--r--lang/node-serialport/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/lang/node-serialport/Makefile b/lang/node-serialport/Makefile
index 87dda6e1f..3c77f177a 100644
--- a/lang/node-serialport/Makefile
+++ b/lang/node-serialport/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NPM_NAME:=serialport
PKG_NAME:=node-$(PKG_NPM_NAME)
PKG_VERSION:=7.1.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NPM_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=https://registry.npmjs.org/$(PKG_NPM_NAME)/-/
@@ -42,6 +42,9 @@ TAR_OPTIONS+= --strip-components 1
TAR_CMD=$(HOST_TAR) -C $(1) $(TAR_OPTIONS)
NODEJS_CPU:=$(subst powerpc,ppc,$(subst aarch64,arm64,$(subst x86_64,x64,$(subst i386,ia32,$(ARCH)))))
+TMPNPM:=$(shell mktemp -u XXXXXXXXXX)
+
+TARGET_CFLAGS+=$(FPIC)
define Build/Compile
$(MAKE_VARS) \
@@ -51,11 +54,11 @@ define Build/Compile
npm_config_build_from_source=true \
npm_config_nodedir=$(STAGING_DIR)/usr/ \
npm_config_prefix=$(PKG_INSTALL_DIR)/usr/ \
- npm_config_cache=$(TMP_DIR)/npm-cache \
- npm_config_tmp=$(TMP_DIR)/npm-tmp \
+ npm_config_cache=$(TMP_DIR)/npm-cache-$(TMPNPM) \
+ npm_config_tmp=$(TMP_DIR)/npm-tmp-$(TMPNPM) \
npm install -g --build-from-source $(PKG_BUILD_DIR)
- rm -rf $(TMP_DIR)/npm-tmp
- rm -rf $(TMP_DIR)/npm-cache
+ rm -rf $(TMP_DIR)/npm-tmp-$(TMPNPM)
+ rm -rf $(TMP_DIR)/npm-cache-$(TMPNPM)
endef
define Package/node-serialport/install