aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-04-12 21:44:17 -0700
committerRosen Penev <rosenp@gmail.com>2021-04-12 22:32:20 -0700
commit1c6dea43a46c24f7af17da1884c53484444d8e32 (patch)
treea0ac1b927040ce23fac3c86fd095b1c8cf37443c
parentc01d0f16cf91be39d19bd1c60c0360213eb8e560 (diff)
meson: update to 0.57.2
Remove upstream backport. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--devel/meson/Makefile4
-rw-r--r--devel/meson/patches/010-options.patch31
2 files changed, 2 insertions, 33 deletions
diff --git a/devel/meson/Makefile b/devel/meson/Makefile
index 9142b1f87..64b31436b 100644
--- a/devel/meson/Makefile
+++ b/devel/meson/Makefile
@@ -1,11 +1,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=meson
-PKG_VERSION:=0.57.1
+PKG_VERSION:=0.57.2
PKG_RELEASE:=$(AUTORELEASE)
PYPI_NAME:=meson
-PKG_HASH:=72e1c782ba9bda204f4a1ed57f98d027d7b6eb9414c723eebbd6ec7f1955c8a6
+PKG_HASH:=3a83e7b1c5de94fa991ec34d9b198d94f38ed699d3524cb0fdf3b99fd23d4cc5
PKG_MAINTAINER:=Andre Heider <a.heider@gmail.com>
PKG_LICENSE:=Apache-2.0
diff --git a/devel/meson/patches/010-options.patch b/devel/meson/patches/010-options.patch
deleted file mode 100644
index c96dabbcd..000000000
--- a/devel/meson/patches/010-options.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 5277eb2232387312c64c79e5622a61cefc26dec0 Mon Sep 17 00:00:00 2001
-From: Dylan Baker <dylan@pnwbakers.com>
-Date: Mon, 5 Apr 2021 13:05:45 -0700
-Subject: [PATCH] coredata: Check for built-in options as host options
-
-These options often don't exist for the build machine, as they're
-generally invalid (ie, prefix, libdir, etc). So we should always check
-for their existance as host optiuons, since all we want to know in this
-case is if the option is yeilding (valid per-subproject), and build/vs
-host doesn't matter in that cases:
-
-Fixes #8613
----
- mesonbuild/coredata.py | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
---- a/mesonbuild/coredata.py
-+++ b/mesonbuild/coredata.py
-@@ -754,7 +754,11 @@ class CoreData:
- if k.subproject and k.subproject != subproject:
- continue
- # If the option is a builtin and is yielding then it's not allowed per subproject.
-- if subproject and k.is_builtin() and self.options[k.as_root()].yielding:
-+ #
-+ # Always test this using the HOST machine, as many builtin options
-+ # are not valid for the BUILD machine, but the yielding value does
-+ # not differ between them even when they are valid for both.
-+ if subproject and k.is_builtin() and self.options[k.evolve(subproject='', machine=MachineChoice.HOST)].yielding:
- continue
- # Skip base, compiler, and backend options, they are handled when
- # adding languages and setting backend.