aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJavier Marcet <javier@marcet.info>2020-03-02 16:01:13 +0100
committerJavier Marcet <javier@marcet.info>2020-06-08 13:49:06 +0200
commit1a5292d17c8b9c1c04a05c1c38ca7025199a08db (patch)
tree6717203f1f18305e859b1eb448b3d34f6e5b5d5f
parent70fe482c410b00b81ee694c5dc9557438b21df42 (diff)
python3-dockerpty: add a new package
Signed-off-by: Javier Marcet <javier@marcet.info>
-rw-r--r--lang/python/python-dockerpty/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/lang/python/python-dockerpty/Makefile b/lang/python/python-dockerpty/Makefile
new file mode 100644
index 000000000..642572749
--- /dev/null
+++ b/lang/python/python-dockerpty/Makefile
@@ -0,0 +1,36 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-dockerpty
+PKG_VERSION:=0.4.1
+PKG_RELEASE:=1
+
+PYPI_NAME:=dockerpty
+PKG_HASH:=69a9d69d573a0daa31bcd1c0774eeed5c15c295fe719c61aca550ed1393156ce
+
+PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE.txt
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+PYTHON3_PKG_SETUP_ARGS:=
+
+define Package/python3-dockerpty
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Python library to use the pseudo-tty of a docker container
+ URL:=https://github.com/d11wtq/dockerpty
+ DEPENDS:=+python3-light +python3-docker +python3-six
+ VARIANT:=python3
+endef
+
+define Package/python3-dockerpty/description
+ Python library to use the pseudo-tty of a docker container
+endef
+
+$(eval $(call Py3Package,python3-dockerpty))
+$(eval $(call BuildPackage,python3-dockerpty))
+$(eval $(call BuildPackage,python3-dockerpty-src))