aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2019-10-01 00:21:14 +0200
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2019-10-01 00:21:42 +0200
commit19e12971b8ac3294e5f22f1e9dd115c91405d88e (patch)
tree452735d0e162064188e37426817b1a5911e5cc8d
parent1ffbba3fb1caf2dda41bb22872d208e39ee0e019 (diff)
Flask: Update to version 1.1.1
- Change TITLE and URL to better one - Add source package Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
-rw-r--r--lang/python/Flask/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/lang/python/Flask/Makefile b/lang/python/Flask/Makefile
index 7b95a32da..63aa47c33 100644
--- a/lang/python/Flask/Makefile
+++ b/lang/python/Flask/Makefile
@@ -5,16 +5,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=Flask
-PKG_VERSION:=1.0.3
+PKG_VERSION:=1.1.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/F/Flask
-PKG_HASH:=ad7c6d841e64296b962296c2c2dabc6543752985727af86a975072dea984b6f3
+PKG_HASH:=13f9f196f330c7c2c5d7a5cf91af894110ca0215ac051b5844701f2bfd934d52
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
PKG_LICENSE:=BSD-3-Clause
-PKG_LICENSE_FILES:=LICENSE
+PKG_LICENSE_FILES:=LICENSE.rst
PKG_CPE_ID:=cpe:/a:palletsprojects:flask
include $(INCLUDE_DIR)/package.mk
@@ -24,8 +24,8 @@ define Package/python3-flask
SECTION:=lang
CATEGORY:=Languages
SUBMENU:=Python
- TITLE:=python3-flask
- URL:=https://github.com/pallets/flask/
+ TITLE:=Flask
+ URL:=https://palletsprojects.com/p/flask/
DEPENDS:=+python3-asyncio +python3-click +python3-codecs +python3-decimal \
+python3-itsdangerous +python3-jinja2 +python3 +python3-logging \
+python3-markupsafe +python3-multiprocessing +python3-setuptools \
@@ -34,9 +34,10 @@ define Package/python3-flask
endef
define Package/python3-flask/description
-Flask is a microframework for Python based on Werkzeug, Jinja 2 and good
-intentions. And before you ask: It.s BSD licensed!
+ Flask is a microframework for Python based on Werkzeug, Jinja 2 and good
+ intentions. And before you ask: It.s BSD licensed!
endef
$(eval $(call Py3Package,python3-flask))
$(eval $(call BuildPackage,python3-flask))
+$(eval $(call BuildPackage,python3-flask-src))