aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Miller <github@mikeage.net>2016-01-27 08:51:50 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2016-02-27 12:21:16 +0100
commit19ae11e91b01873305650315f5b6430c485cb5d3 (patch)
tree5216cd83cd0aae033579112522a5d4be2ed5feb0
parentf326e41adec6efe406b9acfbe3e4c2e68cf172ff (diff)
dump1090: Support cross-compiling (from OS X)
dump1090 doesn't detect cross-compilation; instead, they check uname. For OpenWrt, the target will always be Linux, so just forcibly set it. Signed-off-by: Mike Miller <github@mikeage.net>
-rw-r--r--utils/dump1090/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/utils/dump1090/Makefile b/utils/dump1090/Makefile
index adf8d19ea..bd15db134 100644
--- a/utils/dump1090/Makefile
+++ b/utils/dump1090/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2013-2015 OpenWrt.org
+# Copyright (C) 2013-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dump1090
PKG_VERSION:=2015-11-22
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://github.com/mutability/dump1090.git
@@ -53,7 +53,8 @@ define Package/view1090/description
endef
MAKE_FLAGS += \
- CFLAGS="$(TARGET_CFLAGS)"
+ CFLAGS="$(TARGET_CFLAGS)" \
+ UNAME=Linux
define Package/dump1090/install
$(INSTALL_DIR) $(1)/etc/init.d