aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Ermakov <vooon341@gmail.com>2023-12-23 12:12:33 +0100
committerYousong Zhou <yszhou4tech@gmail.com>2024-02-18 09:18:23 +0800
commit196955742c6ddb334144b05ad0c299e1f7666052 (patch)
tree30f1a6a5db228fdee33db0a64afc53b4c24cd7cb
parent8bcd2447155ea094b99c38dd6514110b8e0b4fc3 (diff)
qemu: update to 8.2.0
- Refresh patches. - Disable new features like AF XDP, Rutabaga VGA, libkeyutils - Delete removed features such as HAX hypervisor Signed-off-by: Vladimir Ermakov <vooon341@gmail.com>
-rw-r--r--utils/qemu/Makefile8
-rw-r--r--utils/qemu/patches/0001-configure-allow-disable-fortify_source.patch2
-rw-r--r--utils/qemu/patches/0010-no-tests.patch4
3 files changed, 8 insertions, 6 deletions
diff --git a/utils/qemu/Makefile b/utils/qemu/Makefile
index 5e9851b06..38b7dc093 100644
--- a/utils/qemu/Makefile
+++ b/utils/qemu/Makefile
@@ -9,10 +9,10 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=qemu
-PKG_VERSION:=8.1.2
+PKG_VERSION:=8.2.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_HASH:=541526a764576eb494d2ff5ec46aeb253e62ea29035d1c23c0a8af4e6cd4f087
+PKG_HASH:=bf00d2fa12010df8b0ade93371def58e632cb32a6bfdc5f5a0ff8e6a1fb1bf32
PKG_SOURCE_URL:=http://download.qemu.org/
PKG_LICENSE:=GPL-2.0-only
PKG_LICENSE_FILES:=LICENSE tcg/LICENSE
@@ -336,7 +336,6 @@ CONFIGURE_ARGS += \
# accel
CONFIGURE_ARGS += \
- --disable-hax \
--disable-hvf \
--disable-whpx \
--disable-xen \
@@ -378,6 +377,7 @@ CONFIGURE_ARGS += \
#
CONFIGURE_ARGS += \
--audio-drv-list='' \
+ --disable-af-xdp \
--disable-attr \
--disable-auth-pam \
--disable-brlapi \
@@ -401,6 +401,7 @@ CONFIGURE_ARGS += \
--disable-libpmem \
--disable-libssh \
--$(if $(CONFIG_QEMU_DEV_USB),enable,disable)-libusb \
+ --disable-libkeyutils \
--disable-linux-aio \
--disable-linux-io-uring \
--disable-lzfse \
@@ -417,6 +418,7 @@ CONFIGURE_ARGS += \
--disable-qom-cast-debug \
--disable-rbd \
--disable-rdma \
+ --disable-rutabaga-gfx \
--disable-sanitizers \
--$(if $(CONFIG_QEMU_SECCOMP),enable,disable)-seccomp \
--disable-smartcard \
diff --git a/utils/qemu/patches/0001-configure-allow-disable-fortify_source.patch b/utils/qemu/patches/0001-configure-allow-disable-fortify_source.patch
index e893c1788..1843df22a 100644
--- a/utils/qemu/patches/0001-configure-allow-disable-fortify_source.patch
+++ b/utils/qemu/patches/0001-configure-allow-disable-fortify_source.patch
@@ -11,7 +11,7 @@ OpenWrt base build system decide flavor of fortify_source to use
--- a/configure
+++ b/configure
-@@ -823,6 +823,8 @@ for opt do
+@@ -757,6 +757,8 @@ for opt do
;;
--gdb=*) gdb_bin="$optarg"
;;
diff --git a/utils/qemu/patches/0010-no-tests.patch b/utils/qemu/patches/0010-no-tests.patch
index 3df92e30d..460f0fab2 100644
--- a/utils/qemu/patches/0010-no-tests.patch
+++ b/utils/qemu/patches/0010-no-tests.patch
@@ -1,6 +1,6 @@
--- a/meson.build
+++ b/meson.build
-@@ -3451,10 +3451,6 @@ subdir('common-user')
+@@ -3513,10 +3513,6 @@ subdir('common-user')
subdir('bsd-user')
subdir('linux-user')
@@ -11,7 +11,7 @@
# accel modules
tcg_real_module_ss = ss.source_set()
tcg_real_module_ss.add_all(when: 'CONFIG_TCG_MODULAR', if_true: tcg_module_ss)
-@@ -3945,10 +3941,6 @@ subdir('scripts')
+@@ -4012,10 +4008,6 @@ subdir('scripts')
subdir('tools')
subdir('pc-bios')
subdir('docs')