aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2020-09-17 19:09:57 +0200
committerSebastian Kemper <sebastian_ml@gmx.net>2020-09-19 20:45:18 +0200
commit177e699ada4a38e98fbe6e5517d0b7cb08d76645 (patch)
tree8f65bed3df31663ba7f98f5ae401303f61baea16
parent0d2e3fa5d4a696fc81b883503b80b4b6802f0377 (diff)
json-glib: bump to 1.6.0
Version bump. New stable branch. ABI_VERSION added. Tests can now be disabled directly. The python3 check is now disabled, as it causes problems with the new Github Action tests. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
-rw-r--r--libs/json-glib/Makefile24
-rw-r--r--libs/json-glib/patches/01-remove-python-check.patch12
2 files changed, 23 insertions, 13 deletions
diff --git a/libs/json-glib/Makefile b/libs/json-glib/Makefile
index a2235ecb3..fdc446472 100644
--- a/libs/json-glib/Makefile
+++ b/libs/json-glib/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=json-glib
-PKG_VERSION:=1.4.4
+PKG_VERSION:=1.6.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=@GNOME/json-glib/1.4
-PKG_HASH:=720c5f4379513dc11fd97dc75336eb0c0d3338c53128044d9fabec4374f4bc47
+PKG_SOURCE_URL:=@GNOME/json-glib/1.6
+PKG_HASH:=0d7c67602c4161ea7070fab6c5823afd9bd7f7bc955f652a50d3753b08494e73
PKG_INSTALL:=1
@@ -35,6 +35,7 @@ define Package/json-glib
TITLE:=JSON GLib Library
URL:=https://wiki.gnome.org/Projects/JsonGlib
DEPENDS:=+glib2
+ ABI_VERSION:=0
endef
define Package/json-glib/description
@@ -44,19 +45,16 @@ RFC 4627.
endef
MESON_ARGS += \
- -Ddocs=false \
- -Dintrospection=false \
- -Dman=false
+ -Dgtk_doc=disabled \
+ -Dintrospection=disabled \
+ -Dman=false \
+ -Dtests=false
-# Disable installed-tests; this also indirectly removes
-# build_aux/gen-installed-test.py calls (copied from Gentoo)
define Build/Prepare
$(call Build/Prepare/Default)
- $(SED) 's/install: true/install: false/g' \
- $(PKG_BUILD_DIR)/json-glib/tests/meson.build
- $(SED) '/install_data/d' \
- $(PKG_BUILD_DIR)/json-glib/tests/meson.build
+ifeq ($(QUILT),)
$(SED) '/error=format=2/d' $(PKG_BUILD_DIR)/meson.build
+endif
endef
define Build/InstallDev
@@ -76,7 +74,7 @@ endef
define Package/json-glib/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson-glib-1.0.so.* \
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson-glib-1.0.so.$(ABI_VERSION)* \
$(1)/usr/lib
endef
diff --git a/libs/json-glib/patches/01-remove-python-check.patch b/libs/json-glib/patches/01-remove-python-check.patch
new file mode 100644
index 000000000..babfcf0b3
--- /dev/null
+++ b/libs/json-glib/patches/01-remove-python-check.patch
@@ -0,0 +1,12 @@
+--- a/meson.build
++++ b/meson.build
+@@ -151,7 +151,8 @@ root_dir = include_directories('.')
+
+ gnome = import('gnome')
+
+-python3 = import('python').find_installation()
++# Python is used only for tests, which we don't build in OpenWrt
++#python3 = import('python').find_installation()
+ gen_installed_test = files('build-aux/gen-installed-test.py')
+
+ subdir('json-glib')