aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Storchak <m.storchak@gmail.com>2014-06-27 10:50:05 +0300
committerMaxim Storchak <m.storchak@gmail.com>2014-06-27 13:19:53 +0300
commit174ee670428e2c7316f14c8600a038738deed2ae (patch)
treee4ab2e0f55130d1ff2a2307205ac5ea10c02b931
parentc9b56fef35fc9eefd9ac25dcf9b5c93cb502733d (diff)
rsync: add support for ACL and XATTR
Signed-off-by: Maxim Storchak <m.storchak@gmail.com>
-rw-r--r--net/rsync/Config.in12
-rw-r--r--net/rsync/Makefile21
2 files changed, 30 insertions, 3 deletions
diff --git a/net/rsync/Config.in b/net/rsync/Config.in
new file mode 100644
index 000000000..c78288069
--- /dev/null
+++ b/net/rsync/Config.in
@@ -0,0 +1,12 @@
+if PACKAGE_rsync
+
+ config RSYNC_xattr
+ bool
+ prompt "Enable xattr support"
+ default n
+
+ config RSYNC_acl
+ bool
+ prompt "Enable ACL support"
+ default n
+endif
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 930d43088..a732722b4 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -26,10 +26,27 @@ define Package/rsync
CATEGORY:=Network
SUBMENU:=File Transfer
TITLE:=Fast remote file copy program (like rcp)
- DEPENDS:=+libpopt +zlib
+ DEPENDS:=+libpopt +zlib +RSYNC_xattr:libattr +RSYNC_acl:libacl
URL:=http://rsync.samba.org/
+ MENU:=1
endef
+define Package/rsync/config
+ source "$(SOURCE)/Config.in"
+endef
+
+ifeq ($(CONFIG_RSYNC_xattr),y)
+ CONFIGURE_ARGS+= --enable-xattr-support
+else
+ CONFIGURE_ARGS+= --disable-xattr-support
+endif
+
+ifeq ($(CONFIG_RSYNC_acl),y)
+ CONFIGURE_ARGS+= --enable-acl-support
+else
+ CONFIGURE_ARGS+= --disable-acl-support
+endif
+
define Package/rsyncd
SECTION:=net
CATEGORY:=Network
@@ -54,8 +71,6 @@ CONFIGURE_ARGS += \
--with-included-zlib=no \
--disable-debug \
--disable-locale \
- --disable-xattr-support \
- --disable-acl-support \
define Package/rsync/install
$(INSTALL_DIR) $(1)/usr/bin