aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-01-17 14:43:04 -0800
committerRosen Penev <rosenp@gmail.com>2019-01-19 12:24:47 -0800
commit16b2c67a9cf7fb8f158b2d6b38312ee77279e43f (patch)
treefa3fc48fe3e85a6e81fa3da57c037463058d9757
parentc7426b1823156527f015bbad8cd7068388d9d834 (diff)
keyutils: Update to 1.6
Add keyctl binary, which can be used to add fscrypt support to ext4 and other filesystems that support it. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--libs/keyutils/Makefile26
-rw-r--r--libs/keyutils/patches/03-cifs.patch13
-rw-r--r--libs/keyutils/patches/04-cflags.patch19
3 files changed, 19 insertions, 39 deletions
diff --git a/libs/keyutils/Makefile b/libs/keyutils/Makefile
index 91b5ca8c3..648b288ac 100644
--- a/libs/keyutils/Makefile
+++ b/libs/keyutils/Makefile
@@ -6,14 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=keyutils
-PKG_VERSION:=1.5.10
+PKG_VERSION:=1.6
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://people.redhat.com/dhowells/keyutils/
-PKG_HASH:=115c3deae7f181778fd0e0ffaa2dad1bf1fe2f5677cf2e0e348cdb7a1c93afb6
-
-PKG_FIXUP:=libtool
+PKG_SOURCE_URL:=https://people.redhat.com/dhowells/keyutils/
+PKG_HASH:=d3aef20cec0005c0fa6b4be40079885567473185b1a57b629b030e67942c7115
include $(INCLUDE_DIR)/package.mk
@@ -21,11 +19,19 @@ define Package/libkeyutils
SECTION:=libs
CATEGORY:=Libraries
TITLE:=Key utilities library
- URL:=http://people.redhat.com/dhowells/keyutils/
+ URL:=https://people.redhat.com/dhowells/keyutils/
+endef
+
+define Package/keyctl
+ SECTION:=utils
+ CATEGORY:=Utilities
+ SUBMENU:=Encryption
+ TITLE:=keyctl
+ DEPENDS:=+libkeyutils
endef
define Package/keyutils/description
- Key utilities library
+ Key utilities
endef
define Build/Install
@@ -44,4 +50,10 @@ define Package/libkeyutils/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libkeyutils.so* $(1)/usr/lib/
endef
+define Package/keyctl/install
+ $(INSTALL_DIR) $(1)/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/keyctl $(1)/bin
+endef
+
$(eval $(call BuildPackage,libkeyutils))
+$(eval $(call BuildPackage,keyctl))
diff --git a/libs/keyutils/patches/03-cifs.patch b/libs/keyutils/patches/03-cifs.patch
deleted file mode 100644
index 6d87633da..000000000
--- a/libs/keyutils/patches/03-cifs.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Author: Marcus Meissner <meissner@suse.de>
-Description: Added 2 cifs helpers to request-key.conf (for CIFS DFS support)
-
-diff -Naurp keyutils.orig/request-key.conf keyutils/request-key.conf
---- keyutils.orig/request-key.conf 2011-08-22 11:46:30.332025250 +0200
-+++ keyutils/request-key.conf 2011-08-22 11:49:40.096967441 +0200
-@@ -38,4 +38,6 @@ create user debug:* expired
- create user debug:* revoked /bin/keyctl reject %k 30 %c %S
- create user debug:loop:* * |/bin/cat
- create user debug:* * /usr/share/keyutils/request-key-debug.sh %k %d %c %S
-+create cifs.spnego * * /usr/sbin/cifs.upcall -c %k
-+create dns_resolver * * /usr/sbin/cifs.upcall %k
- negate * * * /bin/keyctl negate %k 30 %S
diff --git a/libs/keyutils/patches/04-cflags.patch b/libs/keyutils/patches/04-cflags.patch
deleted file mode 100644
index 44f4baa76..000000000
--- a/libs/keyutils/patches/04-cflags.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Author: Nobuhiro Iwamatsu <iwamatsu@debian.org>
-Description: Avoid setting Intel Architecture specific CFLAGS (Closes: #638925).
-
-diff -Naurp keyutils.orig/Makefile keyutils/Makefile
---- keyutils.orig/Makefile 2011-08-22 11:51:20.521464216 +0200
-+++ keyutils/Makefile 2011-08-24 19:17:09.855361713 +0200
-@@ -56,12 +56,10 @@ BUILDFOR := $(shell file /usr/bin/make |
- LNS := ln -sf
-
- ifeq ($(BUILDFOR),32-bit)
--CFLAGS += -m32
- LIBDIR := /lib
- USRLIBDIR := /usr/lib
- else
- ifeq ($(BUILDFOR),64-bit)
--CFLAGS += -m64
- LIBDIR := /lib64
- USRLIBDIR := /usr/lib64
- endif