aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Wagner <tripolar@gmx.at>2014-06-30 15:56:56 +0200
committerPeter Wagner <tripolar@gmx.at>2014-06-30 15:56:56 +0200
commit1696bcef818fedd791e30c3c7c7c17b2a5aae7b6 (patch)
tree8dbdede202e6ba1c6a086f4623e85ab1e59863ac
parent1be5d608eb68d1418deab1b91daf7fd66c675fd8 (diff)
glib2: import from packages and update to the latest version
-rw-r--r--libs/glib2/Makefile100
1 files changed, 100 insertions, 0 deletions
diff --git a/libs/glib2/Makefile b/libs/glib2/Makefile
new file mode 100644
index 000000000..1436f440e
--- /dev/null
+++ b/libs/glib2/Makefile
@@ -0,0 +1,100 @@
+#
+# Copyright (C) 2007-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=glib2
+PKG_VERSION:=2.41.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
+PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
+PKG_SOURCE_URL:=@GNOME/glib/2.41
+PKG_MD5SUM:=bae557c87323e8df7ac30fb484b5cba9
+
+PKG_BUILD_DEPENDS:=glib2/host libpthread zlib libintl libffi
+HOST_BUILD_DEPENDS:=libintl/host libiconv/host libffi/host
+PKG_INSTALL:=1
+PKG_USE_MIPS16:=0
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/glib-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+define Package/glib2
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=$(ICONV_DEPENDS) $(INTL_DEPENDS) +zlib +libpthread +libffi
+ TITLE:=glib 2.0
+ URL:=http://www.gtk.org/
+endef
+
+define Package/glib2/description
+ The GLib library of C routines
+endef
+
+define Build/Configure
+ $(call Build/Configure/Default, \
+ --enable-shared \
+ --enable-static \
+ --enable-debug=no \
+ --disable-selinux \
+ --disable-fam \
+ $(if $(ICONV_FULL),--with-libiconv=gnu) \
+ , \
+ glib_cv_stack_grows=no \
+ glib_cv_uscore=no \
+ ac_cv_path_GLIB_GENMARSHAL=$(STAGING_DIR_HOST)/bin/glib-genmarshal \
+ ac_cv_func_mmap_fixed_mapped=yes \
+ ac_cv_func_posix_getpwuid_r=yes \
+ ac_cv_func_posix_getgrgid_r=yes \
+ );
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/glib-2.0 \
+ $(1)/usr/include/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/glib-2.0/include/*.h \
+ $(1)/usr/include/glib-2.0/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/gio-unix-2.0 \
+ $(1)/usr/include/
+
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/glib-2.0 \
+ $(1)/usr/lib/
+
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} \
+ $(1)/usr/lib/
+
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(INSTALL_DATA) \
+ $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
+ $(1)/usr/lib/pkgconfig
+
+ $(INSTALL_DIR) $(2)/share/aclocal/
+ $(INSTALL_DATA) \
+ $(PKG_INSTALL_DIR)/usr/share/aclocal/*.m4 \
+ $(2)/share/aclocal/
+endef
+
+define Package/glib2/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/*.so* \
+ $(1)/usr/lib/
+endef
+
+$(eval $(call HostBuild))
+$(eval $(call BuildPackage,glib2))