aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-11-27 00:28:12 -0800
committerGitHub <noreply@github.com>2020-11-27 00:28:12 -0800
commit165238242948701982f1a9167d5c86e9cc9fa1e9 (patch)
tree7580007b5aed40119ca153666befc0a10c9de3c0
parent9dd1d919cb7c9f806c6921873f0f5ba7cff0c12e (diff)
parent86e5f1baa9bb6434cc221762776825c3623579ee (diff)
Merge pull request #14034 from nxhack/node_12200
node: update to v12.20.0
-rw-r--r--lang/node/Makefile6
-rw-r--r--lang/node/patches/003-path.patch2
-rw-r--r--lang/node/patches/999-fix_missing_llhttp_depends.patch14
-rw-r--r--lang/node/patches/999-localhost-no-addrconfig.patch2
4 files changed, 5 insertions, 19 deletions
diff --git a/lang/node/Makefile b/lang/node/Makefile
index 947918256..b645b003d 100644
--- a/lang/node/Makefile
+++ b/lang/node/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=node
-PKG_VERSION:=v12.19.0
+PKG_VERSION:=v12.20.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://nodejs.org/dist/$(PKG_VERSION)
-PKG_HASH:=3b671c45c493f96d7e018c15110cdbafa4478e5e5cfc9e6eec83cea9e6b551e1
+PKG_HASH:=61e3fd5c9af565e8d25403ce56b2c0097e2e3270381f2d4216573d48b3dc428b
-PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>, Adrian Panella <ianchi74@outlook.com>
+PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>, Adrian Panella <ianchi74@outlook.com>
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
PKG_CPE_ID:=cpe:/a:nodejs:node.js
diff --git a/lang/node/patches/003-path.patch b/lang/node/patches/003-path.patch
index 8becfa1b6..98d0b1ead 100644
--- a/lang/node/patches/003-path.patch
+++ b/lang/node/patches/003-path.patch
@@ -1,6 +1,6 @@
--- a/lib/internal/modules/cjs/loader.js
+++ b/lib/internal/modules/cjs/loader.js
-@@ -1117,7 +1117,8 @@
+@@ -1109,7 +1109,8 @@
path.resolve(process.execPath, '..') :
path.resolve(process.execPath, '..', '..');
diff --git a/lang/node/patches/999-fix_missing_llhttp_depends.patch b/lang/node/patches/999-fix_missing_llhttp_depends.patch
deleted file mode 100644
index bd6c16f22..000000000
--- a/lang/node/patches/999-fix_missing_llhttp_depends.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -urN a/node.gypi b/node.gypi
---- a/node.gypi 2019-09-05 00:36:25.000000000 +0900
-+++ b/node.gypi 2019-09-13 09:57:54.073191914 +0900
-@@ -149,6 +149,10 @@
- 'deps/http_parser/http_parser.gyp:http_parser',
- 'deps/llhttp/llhttp.gyp:llhttp'
- ],
-+ }, {
-+ 'dependencies': [
-+ 'deps/llhttp/llhttp.gyp:llhttp'
-+ ],
- } ],
-
- [ 'node_shared_cares=="false"', {
diff --git a/lang/node/patches/999-localhost-no-addrconfig.patch b/lang/node/patches/999-localhost-no-addrconfig.patch
index d07d5b814..4d1197321 100644
--- a/lang/node/patches/999-localhost-no-addrconfig.patch
+++ b/lang/node/patches/999-localhost-no-addrconfig.patch
@@ -13,7 +13,7 @@ Forwarded: https://github.com/nodejs/node/issues/33816
//
// Permission is hereby granted, free of charge, to any person obtaining a
// copy of this software and associated documentation files (the
-@@ -1029,13 +1030,6 @@
+@@ -1028,13 +1029,6 @@
hints: options.hints || 0
};