aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2023-03-14 20:54:59 +0100
committerMichael Heimpold <mhei@heimpold.de>2023-03-15 07:32:29 +0100
commit15af23b011ad4248c3bb476dbbd196fce7091075 (patch)
treec6c14829e3e1c49d920a76c8e4d232b47df94474
parent55a015a2b4884b745538954b6b4227a29f4d7ad3 (diff)
swig: enable pcre2 support (refs #20604)
Now since pcre2 provides a host build, let's use it. This is required for e.g. gensio package to provide python bindings. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
-rw-r--r--utils/swig/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/utils/swig/Makefile b/utils/swig/Makefile
index 03378e196..ecd128f52 100644
--- a/utils/swig/Makefile
+++ b/utils/swig/Makefile
@@ -20,6 +20,7 @@ PKG_LICENSE_FILES:=LICENSE
PKG_HOST_ONLY:=1
HOST_BUILD_PARALLEL:=1
+HOST_BUILD_DEPENDS:=pcre2/host
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
@@ -33,7 +34,7 @@ define Package/swig
endef
HOST_CONFIGURE_ARGS += \
- --without-pcre
+ --with-pcre
define Package/swig/description
tool that generates bindings for various languages