aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-04-05 19:53:24 -0700
committerRosen Penev <rosenp@gmail.com>2020-04-06 19:31:52 -0700
commit13278007f9bfe4078862a5ee8b6b479c823aefb9 (patch)
treea2f89c439af36404b64ed1343a07d8a24711c085
parentdb7414eaa9c3f85942363187f41a023926b85bdf (diff)
libv4l: fix compilation under kernel 4.14
The last patch used a macro unavailable with older kernel headers. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--libs/libv4l/Makefile2
-rw-r--r--libs/libv4l/patches/050-4.14.patch13
2 files changed, 14 insertions, 1 deletions
diff --git a/libs/libv4l/Makefile b/libs/libv4l/Makefile
index 21fc5b9c2..100b4dabb 100644
--- a/libs/libv4l/Makefile
+++ b/libs/libv4l/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=v4l-utils
PKG_VERSION:=1.16.6
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://www.linuxtv.org/downloads/v4l-utils
diff --git a/libs/libv4l/patches/050-4.14.patch b/libs/libv4l/patches/050-4.14.patch
new file mode 100644
index 000000000..7cad8ecf5
--- /dev/null
+++ b/libs/libv4l/patches/050-4.14.patch
@@ -0,0 +1,13 @@
+--- a/utils/keytable/keytable.c
++++ b/utils/keytable/keytable.c
+@@ -61,6 +61,10 @@ struct input_keymap_entry_v2 {
+ u_int8_t scancode[32];
+ };
+
++#ifndef input_event_sec
++#define input_event_sec time.tv_sec
++#define input_event_usec time.tv_usec
++#endif
+
+ #define IR_PROTOCOLS_USER_DIR IR_KEYTABLE_USER_DIR "/protocols"
+ #define IR_PROTOCOLS_SYSTEM_DIR IR_KEYTABLE_SYSTEM_DIR "/protocols"