aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Fleurant <meshnet@protonmail.com>2019-09-12 14:28:02 -0400
committerWilliam Fleurant <meshnet@protonmail.com>2019-09-12 14:28:02 -0400
commit1147695a9fd454be8a4d8b6837b5bf2426ede670 (patch)
tree7d20b6694235d98ff36203aca8637a48153a800c
parent61ccd29d374788d12e2371ad8e569ca5ec1deb54 (diff)
yggdrasil: fix #9960 re: vendor fix
Signed-off-by: William Fleurant <meshnet@protonmail.com>
-rw-r--r--net/yggdrasil/Makefile2
-rw-r--r--net/yggdrasil/patches/001-dat-entropia.patch33
2 files changed, 34 insertions, 1 deletions
diff --git a/net/yggdrasil/Makefile b/net/yggdrasil/Makefile
index fd1c52e53..0914205ee 100644
--- a/net/yggdrasil/Makefile
+++ b/net/yggdrasil/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=yggdrasil
PKG_VERSION:=0.3.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/yggdrasil-network/yggdrasil-go/tar.gz/v$(PKG_VERSION)?
diff --git a/net/yggdrasil/patches/001-dat-entropia.patch b/net/yggdrasil/patches/001-dat-entropia.patch
new file mode 100644
index 000000000..0d615d4dc
--- /dev/null
+++ b/net/yggdrasil/patches/001-dat-entropia.patch
@@ -0,0 +1,33 @@
+commit 174ebceaacae482df95e7bb96f0848bb1588a4ff
+Author: Neil Alexander <neilalexander@users.noreply.github.com>
+Date: Sun Sep 1 21:32:40 2019 +0100
+
+ Fix hjson-go import in go.mod/go.sum
+
+diff --git a/go.mod b/go.mod
+index d2ca6b7..6703d5b 100644
+--- a/go.mod
++++ b/go.mod
+@@ -4,7 +4,7 @@ require (
+ github.com/Arceliar/phony v0.0.0-20190831214819-9b642ea019ad
+ github.com/gologme/log v0.0.0-20181207131047-4e5d8ccb38e8
+ github.com/hashicorp/go-syslog v1.0.0
+- github.com/hjson/hjson-go v0.0.0-20181010104306-a25ecf6bd222
++ github.com/hjson/hjson-go v3.0.1-0.20190209023717-9147687966d9+incompatible
+ github.com/kardianos/minwinsvc v0.0.0-20151122163309-cad6b2b879b0
+ github.com/mitchellh/mapstructure v1.1.2
+ github.com/songgao/packets v0.0.0-20160404182456-549a10cd4091
+diff --git a/go.sum b/go.sum
+index f0fbaca..60e6090 100644
+--- a/go.sum
++++ b/go.sum
+@@ -6,6 +6,8 @@ github.com/hashicorp/go-syslog v1.0.0 h1:KaodqZuhUoZereWVIYmpUgZysurB1kBLX2j0MwM
+ github.com/hashicorp/go-syslog v1.0.0/go.mod h1:qPfqrKkXGihmCqbJM2mZgkZGvKG1dFdvsLplgctolz4=
+ github.com/hjson/hjson-go v0.0.0-20181010104306-a25ecf6bd222 h1:xmvkbxXDeN1ffWq8kvrhyqVYAO2aXuRBsbpxVTR+JyU=
+ github.com/hjson/hjson-go v0.0.0-20181010104306-a25ecf6bd222/go.mod h1:qsetwF8NlsTsOTwZTApNlTCerV+b2GjYRRcIk4JMFio=
++github.com/hjson/hjson-go v3.0.1-0.20190209023717-9147687966d9+incompatible h1:bLQ2Ve+eW65id3b8xEMQiAwJT4qGZeywAEMLvXjznvw=
++github.com/hjson/hjson-go v3.0.1-0.20190209023717-9147687966d9+incompatible/go.mod h1:qsetwF8NlsTsOTwZTApNlTCerV+b2GjYRRcIk4JMFio=
+ github.com/kardianos/minwinsvc v0.0.0-20151122163309-cad6b2b879b0 h1:YnZmFjg0Nvk8851WTVWlqMC1ecJH07Ctz+Ezxx4u54g=
+ github.com/kardianos/minwinsvc v0.0.0-20151122163309-cad6b2b879b0/go.mod h1:rUi0/YffDo1oXBOGn1KRq7Fr07LX48XEBecQnmwjsAo=
+ github.com/mitchellh/mapstructure v1.1.2 h1:fmNYVwqnSfB9mZU6OS2O6GsXM+wcskZDuKQzvN1EDeE=
+