aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-11-15 18:52:13 -0800
committerRosen Penev <rosenp@gmail.com>2018-11-17 10:53:06 -0800
commit1114c9d7e045d523d6c193785a4e748f10af5099 (patch)
tree81f28109c76cb84953deefa03d356ba2a03034b3
parent5082cc2cef9de557679c4f16e7039f4c749615f3 (diff)
twisted: Update to 18.9.0
Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--lang/python/twisted/Makefile7
-rw-r--r--lang/python/twisted/patches/001-omit-tkconch.patch2
-rw-r--r--lang/python/twisted/patches/002-omit-tests.patch24
3 files changed, 20 insertions, 13 deletions
diff --git a/lang/python/twisted/Makefile b/lang/python/twisted/Makefile
index 5df2f662f..3b5608d3b 100644
--- a/lang/python/twisted/Makefile
+++ b/lang/python/twisted/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=twisted
-PKG_VERSION:=18.4.0
-PKG_RELEASE:=2
+PKG_VERSION:=18.9.0
+PKG_RELEASE:=1
PKG_SOURCE:=Twisted-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/T/Twisted
-PKG_HASH:=a4cc164a781859c74de47f17f0e85f4bce8a3321a9d0892c015c8f80c4158ad9
+PKG_HASH:=294be2c6bf84ae776df2fc98e7af7d6537e1c5e60a46d33c3ce2a197677da395
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-twisted-$(PKG_VERSION)
PKG_BUILD_DEPENDS:=libtirpc
@@ -39,6 +39,7 @@ $(call Package/twisted/Default)
TITLE:=Python networking engine
DEPENDS:= \
+PACKAGE_twisted:python-light \
+ +PACKAGE_twisted:python-attrs \
+PACKAGE_twisted:python-automat \
+PACKAGE_twisted:python-constantly \
+PACKAGE_twisted:python-incremental \
diff --git a/lang/python/twisted/patches/001-omit-tkconch.patch b/lang/python/twisted/patches/001-omit-tkconch.patch
index 2e5e401a2..1ec4baf0f 100644
--- a/lang/python/twisted/patches/001-omit-tkconch.patch
+++ b/lang/python/twisted/patches/001-omit-tkconch.patch
@@ -1,6 +1,6 @@
--- a/src/twisted/python/_setup.py
+++ b/src/twisted/python/_setup.py
-@@ -143,7 +143,6 @@ _CONSOLE_SCRIPTS = [
+@@ -144,7 +144,6 @@ _CONSOLE_SCRIPTS = [
"conch = twisted.conch.scripts.conch:run",
"mailmail = twisted.mail.scripts.mailmail:run",
"pyhtmlizer = twisted.scripts.htmlizer:run",
diff --git a/lang/python/twisted/patches/002-omit-tests.patch b/lang/python/twisted/patches/002-omit-tests.patch
index 7e8109807..33ba77a0f 100644
--- a/lang/python/twisted/patches/002-omit-tests.patch
+++ b/lang/python/twisted/patches/002-omit-tests.patch
@@ -1,18 +1,23 @@
--- a/src/twisted/python/_setup.py
+++ b/src/twisted/python/_setup.py
-@@ -169,11 +169,6 @@ class ConditionalExtension(Extension, ob
+@@ -169,11 +169,6 @@ class ConditionalExtension(Extension, object):
+
# The C extensions used for Twisted.
_EXTENSIONS = [
- ConditionalExtension(
+- ConditionalExtension(
- "twisted.test.raiser",
- sources=["src/twisted/test/raiser.c"],
- condition=lambda _: _isCPython),
-
-- ConditionalExtension(
+ ConditionalExtension(
"twisted.internet.iocpreactor.iocpsupport",
sources=[
- "src/twisted/internet/iocpreactor/iocpsupport/iocpsupport.c",
-@@ -240,7 +235,7 @@ def getSetupArgs(extensions=_EXTENSIONS)
+@@ -238,12 +233,11 @@ def getSetupArgs(extensions=_EXTENSIONS):
+ "incremental >= 16.10.1",
+ "Automat >= 0.3.0",
+ "hyperlink >= 17.1.1",
+- "PyHamcrest >= 1.9.0",
+ "attrs >= 17.4.0",
]
arguments.update(dict(
@@ -21,11 +26,12 @@
use_incremental=True,
setup_requires=["incremental >= 16.10.1"],
install_requires=requirements,
-@@ -249,6 +244,7 @@ def getSetupArgs(extensions=_EXTENSIONS)
- },
+@@ -253,7 +247,7 @@ def getSetupArgs(extensions=_EXTENSIONS):
cmdclass=command_classes,
include_package_data=True,
-+ exclude_package_data={'':['test/*']},
+ exclude_package_data={
+- "": ["*.c", "*.h", "*.pxi", "*.pyx", "build.bat"],
++ "": ["*.c", "*.h", "*.pxi", "*.pyx", "build.bat", "test/*"],
+ },
zip_safe=False,
extras_require=_EXTRAS_REQUIRE,
- package_dir={"": "src"},