aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-11-06 19:06:38 -0800
committerRosen Penev <rosenp@gmail.com>2018-11-06 19:06:38 -0800
commit10d243a92173236f25d4c42de76a428b6df1a9d6 (patch)
tree173c92967553687747e78706e26737805c0bde1f
parente39273533d6243a9f2fd1daa27a97a3171f7c425 (diff)
openldap: Backport patch to fix compilation without deprecated APIs
Signed-off-by: Rosen Penev <rosenp@gmail.com>
2 files changed, 27 insertions, 1 deletions
diff --git a/libs/openldap/Makefile b/libs/openldap/Makefile
index 6b3d5773f..f167e56a1 100644
--- a/libs/openldap/Makefile
+++ b/libs/openldap/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openldap
PKG_VERSION:=2.4.46
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=https://gpl.savoirfairelinux.net/pub/mirrors/openldap/openldap-release/ \
diff --git a/libs/openldap/patches/800-openssl-deprecated.patch b/libs/openldap/patches/800-openssl-deprecated.patch
new file mode 100644
index 000000000..e6b2d86dd
--- /dev/null
+++ b/libs/openldap/patches/800-openssl-deprecated.patch
@@ -0,0 +1,26 @@
+From d7a778004b0e0c7453075f1c7d429537162df436 Mon Sep 17 00:00:00 2001
+From: Howard Chu <hyc@openldap.org>
+Date: Fri, 21 Sep 2018 18:41:20 +0100
+Subject: [PATCH] ITS#8809 add missing includes
+
+---
+ libraries/libldap/tls_o.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/libraries/libldap/tls_o.c b/libraries/libldap/tls_o.c
+index 010f311d7..99626ec15 100644
+--- a/libraries/libldap/tls_o.c
++++ b/libraries/libldap/tls_o.c
+@@ -43,6 +43,9 @@
+ #include <openssl/err.h>
+ #include <openssl/rand.h>
+ #include <openssl/safestack.h>
++#include <openssl/bn.h>
++#include <openssl/rsa.h>
++#include <openssl/dh.h>
+ #elif defined( HAVE_SSL_H )
+ #include <ssl.h>
+ #endif
+--
+2.19.1
+