aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2020-04-02 16:00:23 -0500
committerW. Michael Petullo <mike@flyn.org>2020-04-06 23:25:39 -0400
commit1022f952ba94d327d7c0d636d33a223fe8728331 (patch)
tree7bba9afd3cf56303db7a108da8ce77d623138a44
parent536d1adc604baede01f4d7dc976f2e907927bd51 (diff)
quota: add new package
Signed-off-by: W. Michael Petullo <mike@flyn.org>
-rw-r--r--utils/quota/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/utils/quota/Makefile b/utils/quota/Makefile
new file mode 100644
index 000000000..a67b4ebf6
--- /dev/null
+++ b/utils/quota/Makefile
@@ -0,0 +1,46 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=quota
+PKG_VERSION:=4.05
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/linuxquota
+PKG_HASH:=ef3b5b5d1014ed1344b46c1826145e20cbef8db967b522403c9a060761cf7ab9
+
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+PKG_LICENSE:=GPL-2.0-or-later
+PKG_LICENSE_FILES:=COPYING
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/quota
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:= quota
+ URL:=https://sourceforge.net/projects/linuxquota/
+endef
+
+define Package/quota/description
+ Utility for managing Linux filesystem quotas
+endef
+
+CONFIGURE_ARGS += \
+ --disable-ext2direct
+
+define Package/quota/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,quota))