aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-12-24 17:40:09 -0800
committerRosen Penev <rosenp@gmail.com>2018-12-24 17:48:09 -0800
commit0fb5bcd3f432899fbc0de9bb6b6188c19c6c90ef (patch)
tree39333e4acebd37da21a87ed165078d3053fb0142
parent724ddd2f94599e96e92fc6c8eb86abf32ac212f6 (diff)
shairport-sync: Allow usage with uclibc++
Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--sound/shairport-sync/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/sound/shairport-sync/Makefile b/sound/shairport-sync/Makefile
index b686659f9..f0759645d 100644
--- a/sound/shairport-sync/Makefile
+++ b/sound/shairport-sync/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=shairport-sync
PKG_VERSION:=3.2.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/mikebrady/shairport-sync/tar.gz/$(PKG_VERSION)?
@@ -23,13 +23,14 @@ PKG_LICENSE_FILES:=COPYING LICENSES shairport.c
PKG_BUILD_PARALLEL:=1
PKG_FIXUP:=autoreconf
+include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
define Package/shairport-sync/default
SECTION:=sound
CATEGORY:=Sound
TITLE:=AirPlay compatible audio player
- DEPENDS:=@AUDIO_SUPPORT +libpthread +libstdcpp +alsa-lib +libconfig +libdaemon +libpopt
+ DEPENDS:=@AUDIO_SUPPORT $(CXX_DEPENDS) +libpthread +alsa-lib +libconfig +libdaemon +libpopt
PROVIDES:=shairport-sync
URL:=https://github.com/mikebrady/shairport-sync
endef