aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey V. Lobanov <sergey@lobanov.in>2022-01-14 20:45:31 +0300
committerRosen Penev <rosenp@gmail.com>2022-01-18 18:09:35 -0800
commit0e6a33a3a444058430c6fe3435fbb70eae464eb4 (patch)
tree3c5a311f7f06e05cdba24840203f1b408f4f57dd
parent042bf16072627d763ba22a4d80c03cb32406a936 (diff)
python-curl: fix build on macos
setup.py detects macos (darwin) and adds -flat_namespace flag. This flag is not compatible with GCC that is used to compile target. This patch patch disables darwin detection Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
-rw-r--r--lang/python/python-curl/Makefile2
-rw-r--r--lang/python/python-curl/patches/100_macos_compat.patch15
2 files changed, 16 insertions, 1 deletions
diff --git a/lang/python/python-curl/Makefile b/lang/python/python-curl/Makefile
index 0e64335d2..630ccd941 100644
--- a/lang/python/python-curl/Makefile
+++ b/lang/python/python-curl/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pycurl
PKG_VERSION:=7.44.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=$(PKG_NAME)
PKG_HASH:=2ce9905626d8ceafcbadee666e2f45397e29c7618ddcdc63fc22d85e5046c6d6
diff --git a/lang/python/python-curl/patches/100_macos_compat.patch b/lang/python/python-curl/patches/100_macos_compat.patch
new file mode 100644
index 000000000..fc233da2a
--- /dev/null
+++ b/lang/python/python-curl/patches/100_macos_compat.patch
@@ -0,0 +1,15 @@
+Support build on MacOS
+This patch should be deleted after resolving https://github.com/pycurl/pycurl/issues/727
+---
+--- a/setup.py
++++ b/setup.py
+@@ -347,9 +347,6 @@ manually. For other SSL backends please
+ if not self.libraries:
+ self.libraries.append("curl")
+
+- # Add extra compile flag for MacOS X
+- if sys.platform.startswith('darwin'):
+- self.extra_link_args.append("-flat_namespace")
+
+ # Recognize --avoid-stdio on Unix so that it can be tested
+ self.check_avoid_stdio()