aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-01-06 21:02:59 -0800
committerRosen Penev <rosenp@gmail.com>2019-01-06 21:02:59 -0800
commit0e4b4f66a2f71a7f319379d3120f14e3a7dc0d63 (patch)
treeb8cfcb1a0071ddc0d9e7c3b41372251d2f36fc46
parent483c9fceae100dd7c205c614a35907ecc9496965 (diff)
squid: Fix compilation without OpenSSL ENGINE support
OpenSSL 1.1 includes the header but support has to be checked in another way. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--net/squid/Makefile2
-rw-r--r--net/squid/patches/010-openssl-engine.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/squid/Makefile b/net/squid/Makefile
index 19c5786ab..4433d0668 100644
--- a/net/squid/Makefile
+++ b/net/squid/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=squid
PKG_VERSION:=4.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-2.0
PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr>
diff --git a/net/squid/patches/010-openssl-engine.patch b/net/squid/patches/010-openssl-engine.patch
new file mode 100644
index 000000000..e7f97eec5
--- /dev/null
+++ b/net/squid/patches/010-openssl-engine.patch
@@ -0,0 +1,11 @@
+--- a/src/ssl/support.cc
++++ b/src/ssl/support.cc
+@@ -485,7 +485,7 @@ Ssl::Initialize(void)
+
+ SQUID_OPENSSL_init_ssl();
+
+-#if HAVE_OPENSSL_ENGINE_H
++#ifndef OPENSSL_NO_ENGINE
+ if (::Config.SSL.ssl_engine) {
+ ENGINE_load_builtin_engines();
+ ENGINE *e;