aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Matouschek <felix@matouschek.org>2023-11-27 11:12:03 +0100
committerRosen Penev <rosenp@gmail.com>2023-12-01 11:24:34 -0800
commit0db2d278012f26da91c0959b18d0b3a77efbf568 (patch)
tree4443ccf31b90999653bce53df4a0c56aa795cd44
parent562f5df67fd9436dface35a410e9ce591d9a2894 (diff)
postfix: Fix enabling PCRE support
After the change from PCRE to PCRE2 when enabling POSTFIX_PCRE the resulting postfix build no longer reports pcre as an available module. (postfconf -m). This is caused by using the wrong syntax for the HAS_PCRE build flag (HAS_PCRE2 vs HAS_PCRE=2). This fixes the build flag to use the correct syntax. Signed-off-by: Felix Matouschek <felix@matouschek.org>
-rw-r--r--mail/postfix/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/mail/postfix/Makefile b/mail/postfix/Makefile
index 313713692..5fbecf125 100644
--- a/mail/postfix/Makefile
+++ b/mail/postfix/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=postfix
PKG_VERSION:=3.8.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:= \
@@ -172,7 +172,7 @@ ifdef CONFIG_POSTFIX_PGSQL
endif
ifdef CONFIG_POSTFIX_PCRE
- CCARGS+=-DHAS_PCRE2 -I$(STAGING_DIR)/usr/include/
+ CCARGS+=-DHAS_PCRE=2 -I$(STAGING_DIR)/usr/include/
AUXLIBS+=-L$(STAGING_DIR)/usr/lib -lpcre2-8
else
CCARGS+=-DNO_PCRE